iMac will not load Canon printer software, please help!

Discussion in 'Mac Basics and Help' started by ajax25, Oct 31, 2010.

  1. ajax25 macrumors newbie

    Joined:
    Oct 31, 2010
    #1
    Hello. Recently I purchased a Canon PIXMA MG5220 wireless printer. I have installed numerous printers, software, hardware etc on other comps as well as this one and have never had a problem... until now. I connected my printer to the internet access port (my home network) and everything went fine. But when I put in the canon disk to load the software and add the printer to my comp, I click on setup, it prompts me for my user pw to allow install. I do that and when I hit ok, nothing happens... No other window loads or anything. It's like there is nothing on it after the pw prompt. I tried it on a diff comp (windows based PC) and it worked fine... why wont it load on my iMac? Very confused. Also, I turned off my firewall thinking that would help, but it did not... any help is appreciated. Thank you!

    Sincerely,
    Ajax
     
  2. ajax25 thread starter macrumors newbie

    Joined:
    Oct 31, 2010
    #3
    Downloaded all drivers and software. Still nothing when disk is loaded. Everything is fine untill I enter my CORRECT pw for install, then nothing happens... the canon prompt screen for install never comes up...
     
  3. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #4
    Is this not a wireless printer ? are you connecting by ethernet or USB ?

    Normally Canon's drivers like to be installed while the printer is connected by USB. Are you using Apple's software update to get the drivers - many of the Canon drivers don't install properly in OSX 10.6.....
     
  4. ajax25 thread starter macrumors newbie

    Joined:
    Oct 31, 2010
    #5
    I am running OS X 10.4.11 and yes it is wireless. Why would I need to connect via USB if it's wireless. I shouldn't have to search for and download drivers for something that is supposed to setup easily out of the box. Doesn't seem user friendly at all. Gonna try to upgrade to OS X 10.5 and see if that works. Currently I am deleting free space on my HD. I tried to boot from my install disc but it said "Mac OS X Install Disc 1 could not be used as startup disc, please make sure the disc is in the drive" IT IS IN THE DRIVE!
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #6
    Try with USB to see if the printer works.

    Then, contact printer maker for support.

    Most printers do not even need manual driver install to work on Mac OS X.
     

Share This Page