iMac WinXp ATI HD 2600 XT Graphics update failed

Discussion in 'Windows, Linux & Others on the Mac' started by h1v3, Sep 27, 2008.

  1. h1v3 macrumors newbie

    Joined:
    Sep 27, 2008
    #1
    Hi guys!

    Have an 1yo iMac with an ATI HD 2600 XT and I'm running Win Xp via Bootcamp!
    Iwanted to update the GCard drivers... I uninstalled the old ones and then downloaded from the ATi website the "§$"§$ Catalyst 8.9 (should be compatible with my card).
    Every time i try to install the Drivers an error occurs telling me "There is no matching hardware on your pc"...
    Even tried the Mobility Package... in vain
    I'm kinda perplexed now.

    Please help me guys!

    greetings
    Mario
     
  2. Namnorkimo macrumors member

    Joined:
    Oct 11, 2008
    #2
    ATI offers drivers for the non-mobility cards only. The ATI in your iMac is a ATI mobility radeon HD 2600 XT! The only ATI driver that workes in replacement is the one for the ATI Radeon HD 2600 pro, but that made no difference in compatiblity or performance. If you like to get more performance out of your XT card, use the ATI tool and clock the core to 837 mhz and the memory to 846 mhz. That will give you a speed-increase of 20 %.
     

Share This Page