iMac with Mavericks loses internet connection (browsers only)

Discussion in 'OS X Mavericks (10.9)' started by MacManX, Feb 5, 2014.

  1. MacManX macrumors member

    Joined:
    Jan 17, 2004
    Location:
    Sweden
    #1
    I have a very strange issue. My 21.5" mid 2011 iMac with Mac OS X Mavericks 10.9 has, since upgrading to 10.9.1, started to lose its internet connection from time to time (once a day).

    It has full access to the entire local network AND the VM Ware Fusion Windows XP running on the same machine has full internet access. I can use apps like Skype - but no browser. I have Safari, Firefox and Opera installed - they cannot access ANY web site what so ever. App Store does not work.

    The only way to restore the connection is to reboot the computer.

    - Re-starting the browsers does not help
    - Changing from Ethernet to WiFi does not help
    - Re-arranging the connections in Network Settings does not help
    - Renewing DHCP does not help
    - Setting the IP-address manually to something else does not help
    - Deleting the network in Network Settings does not help
    - Deleting the files "NetworkInterfaces.plist" and "preferences.plist" does not help
    - It is not a sleep issue. Sleep mode is OFF
    - It is not a DNS issue
    - The Mac OS X Firewall is OFF
    - The network settings for Max OS X and the virtual Win XP are identical except the local IP-address

    Please, someone, HELP ME!!
    I have posted this twice in Apple Support Communities - only one answer, a guy with the same problem...
     
  2. MacManX thread starter macrumors member

    Joined:
    Jan 17, 2004
    Location:
    Sweden
    #2
    Seriously? Noone has an answer?? :confused:

    This problem is really annoying... every morning when I arrive at work - all browsers are dead. Mail, Evernote and Skype works as does the internet connection in VMware Fusion.
     
  3. empp macrumors newbie

    Joined:
    Feb 27, 2014
    #3
    Having same problem on iMac

    I hope someone can help. This is very upsetting. My Mozilla Thunderbird works fine, but Safari, Chrome and Firefox either will not produce a web page or will take forever to accomplish this. Sometimes if the page comes up it is without any styling or pictures. Same problem with Firefox in Safe Mode. The App Store is not working, but iTunes works fine. Thanks to anyone who can come up with solution!
     
  4. petvas macrumors 601

    petvas

    Joined:
    Jul 20, 2006
    Location:
    Mannheim, Germany
    #4
    I had this last week for the first time and rebooted my Mac too. I dont know what was wrong with it, but it was strange. I hope 10.9.2 fixed whatever bug that caused it.
     
  5. Webber, May 13, 2014
    Last edited: May 13, 2014

    Webber macrumors newbie

    Joined:
    Apr 20, 2008
    #5
    Had something similar, found a solution

    I have had something similar and completely out of the blue after a restart:
    - Browsers: no access to internet;
    - App Store: no internet access;
    - Mail application (Outlook in my case): no internet access;
    - Local network accessable;
    - Network Tool application could ping websites (so apparently there was internet);
    - DHCP renewed hundreds of times;
    - Flushed DNS cache;
    - Changing from ethernet to WiFi: no access to internet;
    - No sleep Mode activated;
    - Re-installing and restarting browsers: no access to internet;
    - Fushing all caches browser related: no access to internet;
    - Internet assistant application telling that there seems to be no problem;
    - Tried re-installing complete OS;
    - Deleted and re-added all network accounts;
    - Deleted all possibly related plist files and complete system configuration;
    - Checked my Firewall and security settings;
    - Have tried numerous solutions found online (including drinking black coffee whilest being upside down :rolleyes:), nothing worked;

    - Other computers in same network: no problems with access to internet ...:eek:

    Then after many, many hours and some more hours I found what was wrong:
    - In System preferences, I opened Network;
    - On the left I choose my network connection (Ethernet in my case);
    - Then I set Configure IPv4 to DHCP with manual address (it was set as DHCP);
    - Then I opened Advanced;
    - In Advanced I opened DNS tab;
    - There only my router's address was added(?), although being gray;
    - I then added 8.8.8.8 (DNS server of Google) and saved all;
    - Internet worked immediately again.
    - I then added some extra DNS servers, from my isp, just to be sure.

    I suspect that somehow, maybe through an earlier crash, or possibly even through some cleaning application (Mac Tune Up, MacKeeper etc), something changed with these settings.

    Hope this helps somebody.
     
  6. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
    #6
    I had it happen a couple time under Mavericks since Oct 2013. I repaired permissions and restarted and all was well.
     
  7. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #7
    Do any of you have a Google Now app? It was a cause of this problem at first of Mavericks until it was updated.
     
  8. anyasy macrumors newbie

    Joined:
    May 31, 2014
    #8
    Argh! After installing the last Mavericks update (by accident!) I now have the exact same problem. Tweetdeck works, but Chrome, Firefox and Safari don't work. T_T No Google Now app.
     
  9. GPap macrumors regular

    GPap

    Joined:
    May 5, 2014
    #9
    1) Go to Macintosh HD->Library->Preferences and delete the folder SystemConfiguration. Restart.

    2) If the step 1 doesn't work change your router encryption to WPA2.

    These steps worked for me.
     

Share This Page