iMac with Snow Leopard takes 20 mins to start up

Discussion in 'macOS' started by lofight, Oct 30, 2010.

  1. lofight macrumors 68000

    lofight

    Joined:
    Jun 16, 2007
    #1
    The problem is, each time I restart my computer or put it back on again, it takes around 20 mins to start up. At the grey screen there is a grey bar that takes 20 mins to load...

    Should I reinstall snow leopard?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
  3. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #3
    Reset SMC and PRAM and run Disk Utility. Also see the clean installation as said above.

    Any other weird behavior like long app launch times? If there are, then your HD may be on its last legs
     
  4. lofight thread starter macrumors 68000

    lofight

    Joined:
    Jun 16, 2007
    #4
    Yes that's the one. I have 47 GB free + a windows partition which I could delete. I already have Snow Leopard and I would rather not clean install it. I don't want to back-up everything...

    I'll try resetting SMC and PRAM. My apps launch fast...
     
  5. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #6
    Why don't you want to back up? It's so easy with Time Machine. I just installed a new HDD the other day and did a clean SL install and used the Time Machine backup to restore my files and settings.

    If I didn't know my HDD was replaced I wouldn't have noticed that I had anything done to the OS.

    Backing up is very essential to preventing data loss.
     

Share This Page