iMac won't boot from Snow Leopard Disk

Discussion in 'iMac' started by rhsauer, Nov 8, 2010.

  1. rhsauer macrumors newbie

    Sep 26, 2006
    I have a 27" iMac, about a year old. Yesterday, when I read a "Verify Disk" on the HD, it told me that the startup disk needed to be repaired, requiring that I boot from my Snow Leopard install disk, but the computer won't book from the disk. It just stops on a grey screen with an apple logo - no turning cog or other action. I have tried the following:

    1. I tried another Snow Leopard install disk, to see if the first was faulty. The iMac still refuses to boot, so I doubt it's the optical disk itself.

    2. I tried the 10.4 install disk that came with the iMac. Same problem.

    3. I held down the "C" key throughout the bootup process. Same problem.

    4. I held down the "Option" key throughout the bootup process. Same problem.

    5. I went to Setup/Startup Disk and directed it to startup from the Snow Leopard install disk. Same problem.

    6. I cleared the PRAM and the NVRAM. Same problem.

    If I hold the eject button down thought the boot process, the SL install disk ejects, and the computer starts up normally, and it runs fine (except running verify disk still tells me the startup disk needs to be repaired). When the computer is running, the optical drive reads disks (including the SL install disks) just fine - it just won't boot from an optical disk.

    One thing that occurs to me as I write this is that the iMac is set to start in 64 bit mode. That shouldn't matter - but I may set it to 32 and see if it helps. All updates to Snow Leopard have been installed. No non-factory ram is installed.

    Any other thoughts? Help!
  2. Hellhammer Moderator


    Staff Member

    Dec 10, 2008
  3. MacHamster68, Nov 8, 2010
    Last edited: Nov 8, 2010

    MacHamster68 macrumors 68040


    Sep 17, 2009
    does the install disc mount on the desktop? then install and restart from there once you get ask for, btw sometimes it takes ages for the disc to load once restarted i see the apple logi on my intel iMac for ages before the turning circle comes up , so from restart to install it takes a good 10 minutes before the menu comes up asking for language settings ,dont know why that is as on my other pre intels it takes only seconds ,
    if it doesn't mount try other disc as it could be the superdrive gone , hope you got apple care then,
  4. rhsauer thread starter macrumors newbie

    Sep 26, 2006
    Interesting - I've probably given up at 5 minutes, thinking that if nothing happens after 5 minutes, nothing is going to happen. I'll let it go 10 minutes tonight and see if it works. Thanks.
  5. rhsauer thread starter macrumors newbie

    Sep 26, 2006
    Well, it doesn't book from the optical disk no matter how long I wait. Again, the optical drive sees the disk just fine when OSX is booted from the HD. Any further thoughts?

    (I was able to repair the problems reported with my HD using Applejack.)
  6. Hellhammer Moderator


    Staff Member

    Dec 10, 2008
    Try making a copy of the DVD to an USB drive and try booting from that
  7. wandal macrumors newbie

    Feb 17, 2010
    Just the same here.

    A few days ago I lost my "service" USB flash memory, containing Mac OS X, 10.6.5 combo updater, and mixed updaters.

    So I've cloned again the Snow Leopard Install DVD (10.6.1 I suppose) on a USB flash memory. To check it out, I tried to boot from there my late 2009 iMac 27" i7 8GB (OS X 10.6.5 perfectly working), with no success.

    I tried to boot from the original Install DVD, no success.

    It just stops at the grey screen with the apple logo. I just press the power button, and the iMac switches off immediately (no processes hanged, it seems).

    I am a little worried about it. I think the reason is in firmware updates, that brought the iMac in a newer state (as of 10.6.5) with respect to the Install DVD (10.6.1), so the boot is not feasible.

    Hope somebody can explain the problem to us.
  8. arsen32 macrumors newbie

    Jan 15, 2008
    Please help.

    Has anyone found a solution to this problem. I have an iMac from 2008 that I am trying to upgrade to snow leopard. No matter what I try I cannot get it to boot from the dvd.

    1) Holding c when booting
    2) Letting it install the materials then reboot
    3) Also tried using the DVD as the startup says restart using this as startup disk and doesn't do anything
    4) I reset the pram and nvram

    Any ideas?
  9. product26 macrumors 6502a


    May 30, 2005
    My 27" 2010 imac wont boot from my snow leopard dvd because it is version 10.6.0 and the imac shipped with and requires a higher version. I can only get it to boot from the original restore dvd.
  10. Edouard macrumors newbie

    Feb 26, 2011
    I've had a problem similar to yours, but caused by something else.
    My Macbook pro wouldn't boot from the disk where Mac OS X was installed, it just kept on shutting down.
    I tried inserting the Mac OS X installation disk, pressing C/Alt but it kept being ejected no watter what I did.
    Anyway, after hours and hours I've finally come across a solution.

    1) Back up every important data you have
    2) Get an Ubuntu Live CD (
    3) Insert the live CD into your Mac, restart, and press "Alt" when you hear the startup sound
    4) Boot from the Ubuntu Live CD (click on "try" not install)
    5) Go to
    6) Click on one of the links, then open the downloaded file with "Ubuntu Software Center"
    7) While in the Ubuntu Sofware Center, search for "hfsplus" and install the package

    8) Go to Applications->Accessories -> Terminal
    9) Type in: "sudo gparted"
    10) You will see a window come up, that is the partitioning tool
    11) Select your disk
    12) Click on "Device" in the upper menu -> Create a partition table
    13) You will now create 2 partitions with the following characteristics.
    -a) size: 200Mb, Label: EFI, Format: FAT32
    -b) size: the rest of the disk, Label: Macintosh HD, Format: HFS+

    /!\/!\/!\ WARNING: This will entirely erase everything on the disk /!\/!\/!\

    14) Hit the green "V" (apply)
    15) Let Ubuntu work its magic... then shutdown the computer and eject the disk.

    16) Insert the Mac OS X installation disk
    17) Press the "Alt" key when you hear the startup sound

    You can now boot from the Mac OS X installation disk.
    If you try to install it to the Macintosh HD drive, you will get the message "cannot be used to start up your computer".
    To solve this minor issue, do the following:

    1) In the upper bar, click on Utilities -> Disk Utility
    2) Select the Macintosh HD partition
    3) Go to the "Erase" tab
    4) Select "Mac OS X extended (journaled)"
    5) Type in "Macintosh HD" (or whatever name you like) in the text field
    6) Hit apply
    7) Quit disk utility

    After doing this, you will be able to properly install Mac OS X onto the disk.

    Hope this helps
  11. torrealta macrumors newbie

    Jan 20, 2010
    USB Interference

    After more trouble than I'll bore you with, the answer for me was to disconnect my USB devices.
  12. wickit007, Feb 22, 2012
    Last edited: Feb 22, 2012

    wickit007 macrumors newbie

    Feb 22, 2012

Share This Page