iMac won't boot - please help!

Discussion in 'iMac' started by Travisimo, Aug 13, 2013.

  1. Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #1
    I have a late 2009 iMac running Mountain Lion that I leave on 24/7. I haven't used it in a couple of days, and when I went to use it this morning, something major is wrong. Firstly, my mouse would not wake it up, which wasn't a big concern. I pressed a button on the keyboard and it woke up. I could see my desktop with a message "Time Machine could not backup" or something like that. There was a also a spinning circle and nothing was responsive. So I long-pressed my power button and shut down the computer.

    When I powered back on, the Apple logo appeared, but also a gray bar underneath it that began to fill up. The bar seemed to fill up, but then the computer just shut down again. I tried this one more and it did the same thing. So I don't think it's going to boot up.

    I booted into recovery by holding Option when starting the comptuer, and then went into Recovery (not my Time Machine, just normal Recovery). I started Disk Manager and I can see all of my drives. My main 1TB drive (internal on my Mac) showed the main drive and then Macintosh HD, which was not mounted. I also saw my Time Machine external drive that was also not mounted. I attempted to Repair my Macintosh HD disk, but it said it could not be repaired. Uh oh, I don't think this is good.

    Then I tried to Verify my external drive that has the Time Machine on it. It said it needed to be repaired. I clicked on Repair and it is currently in the process of repairing. It said it checked the file system, volume repair complete, and now it has been on "Updating boot support partitions for the volume as required." for several minutes now with no sign of progression. I don't know if it's going to complete or not, but I'm leaving it alone for now.

    SOOO.... I'm trying to understand what happened? I assume my main Macintosh HD drive failed, either during a Time Machine backup, or perhaps it tried to backup to Time Machine when it started failing? I don't know because like I said, I haven't used the iMac for several days, so I'm not sure when it happened or how long it's been. However, if my Time Machine drive is failing too, that doesn't make sense, does it, unless it got corrupted when the main drive failed?

    I need advice on how to proceeed? If the Time Machine drive succesfully repairs, then I will try to boot from that, right? If it does not repair, then what do I do? I believe I have most of my data backed up on Crashplan, but not everything... and if both of the drives failed or corrupted, am I just out of luck? I think it's highly unlikely that both drives have physically failed, but if they are both now corrupted, then how do I get my data off of one of them? I do have a newer Mac Mini running in the other room, so I don't know if that would help or not?

    I appreciate any help...
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    By the looks of things, the drive in your iMac may be on it's way out...If you have the original media that came with your Mac, try running the AHT ( Apple Hardware Tests) by booting from the installation media:

    More info here:

    http://support.apple.com/kb/ht1509
     
  3. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #3
    The repair on my Time Machine eventually timed out and I stopped it.

    However, my "Macintosh HD" drive is now mounted. So I clicked on "Verify Disk Permissions" and it went through the whole verify process, showing my the folders it was checking, etc. So it must be reading the drive... It showed some permission errors and told me to Repair Disk Permissions. However, that option is grayed out.

    So then I clicked on "Verify Disk" and it went through that whole process as well, showing some errors but completing and telling me to run Repair Disk. But again, that option is also grayed out. If I hover my mouse over it, it says ""Not available because the selected disk can't be written to".

    Does that mean my drive is stuck in a read-only state, perhaps because of a failed update or something (I though I read somewhere about this happening if an OS update fails).

    At any rate, the drive is definitely working (at least reading). Very strange that my external drive is also not working, so I'm suspecting it was some kind of corruption during an update or backup. However, I'm not sure if I am going to be able to recover without reformatting everything on both drives.

    Any other suggestions?
     
  4. glindauer macrumors newbie

    Joined:
    Aug 12, 2013
    #4
  5. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #5
    Thanks, but those did not work. The computer does the same thing every time I try to boot it now: Apple logo with spinning circle and then the gray bar below it that slowing starts filling up until the screen goes black and the iMac turns off.

    I can boot into recovery, but neither my Macintosh HD nor my external Time Machine will successfully "Repair" if I try to repair them from Disk Utility.

    At this point, I don't think I am going to recovery the OS without a format and reinstall. Unfortunately, if my Time Machine disk hadn't gotten corrupted as well, I could just recover from that. But as it stands, I now need to determine whether it's a physical hard drive failure, or whether it just got corrupted (the file system, more than likely) beyond repair?

    Between Crashplan and a couple of other external hard drives that are still working, I have about 90% of the data backed up. But I would still like to be able to look at my Macintosh HD drive to back up anything else if at all possible? Since Disk Utility was able to read from it, is there any way for me to mount it from another computer? Or could I install the OS onto a USB drive and boot from that to try and look at the Macintosh HD drive?

    EDIT: If I try to boot from my Time Machine external drive by holding Option at bootup, it does EXACTLY the same thing as when I try to boot from the internal drive: it shows the Apple logo with the gray bar at the bottom and eventually just turns off. So trying to boot from either drive seems to be starting Safe mode automatically and then failing to fix the problems.

    The chances of both of these drives having a physical failure at the same time is very slim, IMO, so I can only assume that something caused a file system corruption on both drives. Aren't there supposed to be safeguards against this for Time Machine? I mean, if the drive on my main system fails or gets corrupted, shouldn't the OS be smart enough not to cause the Time Machine backup to also get corrupted?
     
  6. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #6
    'Any other suggestions?'

    Yup.

    If you had used CarbonCopyCloner (or SuperDuper) to mainatin a bootable clone of your internal drive (instead of Time Machine, which you cannot boot from), you'd have a "second boot source" that you could connect and attempt to boot from.

    Even if the internal drive has a problem (either software or hardware), if there are no other problems with the iMac you can boot right up from the clone and be back in business in a couple of minutes.

    From that point, you can "attack" the internal drive with repair software or even do a re-installation of the OS.

    But -- with only a TM backup, and no other way to boot except from an internal drive that is having problems, you are left stumbling about as you are now.

    So... in the future, keep a bootable clone backup around, as well as a TM backup, and it will make "moments like this" more easily resolved...
     
  7. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #7
    It sounds like it could be Hard Drive related.

    Some of these model iMacs had Seagate drives that were recalled by Apple a while back. You can check your model is involved by putting your iMac's S/N in here. The recall period has expired. However, in some cases Apple is still replacing the drives without charge. If yours falls into this category, I'd give Applecare a call and see what they say (not the Genius Bar at a store)
     
  8. Travisimo, Aug 13, 2013
    Last edited: Aug 13, 2013

    Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #8
    Thanks, I will certainly do that in the future. I do, in fact, do that on my Windows machine. I don't know why I thought I could rely on Time Machine for my iMac... guess I should have known better.

    ----------

    Thanks for this, but after checking, my unit is not affected by this.

    I have yet to try reformatting the drive and reinstalling the OS. I wanted to make sure I exhaust all other troubleshooting steps first. However, once I have done that, do I just reformat from within Disk Utility? My iMac originally came with Snow Leopard, I believe.... do I have to install that OS first, then upgrade multiple times back up to Mountain Lion? Or is there a way to install Mountain Lion directly onto the computer? Maybe from Internet Recovery?

    NOTE: If I click on the drive itself from Disk Utility and run the "Repair Disk", it reports that the disk is fine. It's only when I click on the Macintosh HD volume and run "Repair Disk" that it cannot repair. The same is true on my external TM drive: if I click on the higher level disk, it shows that it is fine, but if I click on the TM volume, it fails the repair. I assume this likely means that the drives themselves are fine but somehow the file system got corrupted on both? So I should be able to reformat and reinstall the OS and continue using the drive, right? Of course, I don't know what caused the problem to begin with, so I'd have to monitor my system for a while...
     
  9. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #9
    Did you try the Apple Hardware Test that's on your original DVDs that came with the iMac, as was previously suggested? You could also try holding down "D", or Option + D during boot to see if that brings up AHT. That could show a problem Hard Drive.

    If you boot into the Recovery partition, you can reformat and restore Mountain Lion over the internet. However, it's sounding like you have a failing HDD. When you run "Repair Disk" with the disk selected, it checks and repairs the format and partition data. When you "Repair Disk" on the Volume, it checks and repairs volume and OS data.

    If your drive has bad block(s), data written to those areas is corrupt and unreadable. Time machine may also have copied (or tried to copy) the bad data resulting in a failed backup. Cloning software will also fail if there is corrupt data on a disk.

    Since you cnan still access the disk, if you were to install Mountain Lion onto an external disk, you could likely access and recover most of the data on the problem HDD.

    If you do try and reformat the disk, you should write zeros to it so it can map any bad blocks on the drive. Just remember if there are bad blocks, it means the disk is failing.

    If you do restore the OS from the restore partition, you may be able to fully restore your system from a previous Time Machine Backup. When did you first have trouble with the system booting up? A time machine backup from prior to this date may allow you to restore your personal data.
     
  10. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #10
    Thanks for your help, first of all... Now then,

    1) I tried to start the AHT by putting in my DVD that has this utility on it, but I can't get it to come up with either "D" or "Option + D" at startup. Do you hold down the key right before the gray screen comes on, right after, or what? I've tried several times. The "Option" key works fine to bring up the boot options but I can't get AHT to come up with or without the DVD in the drive.

    2) I can't use a previous Time Machine backup because my external disk that has Time Machine is also unreadable. So are you saying if install the OS to a totally different drive and then mount the TM drive, I might be able to copy the TM backup from the bad drive and then try to restore it that way?

    3) Or I could leave my internal disk alone, reformat the external drive that has TM on it (since it's not repairable anyway), install the OS to it and then boot to it to see if I can see the data on my internal drive?

    4) So yeah, in Disk Utility it only has errors when I try to repair the volumes. If I run it on the disk itself, everything seems fine. From this alone, are you saying it's likely that the drive(s) are bad or that just the volumes are bad?
     
  11. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #11
    Making a *little* progress. No matter what I did in Disk Utility, I could not get my external drive to reformat, repartition, or erase. It gave me errors no matter what and would either get stuck "unmounting" or just flat out gave me an error.

    So I uplugged it and plugged it into my Windows 8 computer. From there, I was able to reformat the drive. Then I plugged it back into my iMac with Recovery running Disk Utility, and NOW it is able to be partitioned and reformatted.

    So I am now installing Mountain Lion on the external drive so that I can boot to it and hopefully see the contents of my internal drive. Don't know if that'll work or not.

    Unfortunately, I cannot plug my internet drive into my Windows 8 computer and reformat it. But perhaps if I am booting from the external drive, I will be able to access the internal drive. At this point, I just want to determine whether the internet drive is useable or not. I'm thinking that neither drive actually went bad but just got corrupted during an update or something...
     
  12. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #12
    Ok, I've gotten the internet drive reformatted and ready to reinstall the OS. I am currently booting to Mountain Lion from an Internet Recovery install to my external drive.

    How do I properly "write zeros" to my internal drive to make sure it is functioning properly. Do I do this in Disk Utility?
     
  13. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #13

    In Disk Utility, Under the Erase Tab, at the bottom of the window there is a button that says "Security Options". In there, slide the slider one notch. Depending on the size of your drive, it will take a while.
     
  14. dr.oid macrumors newbie

    dr.oid

    Joined:
    Aug 11, 2013
    #14
    iMac boot problem

    have you reformatted your iMac HD and reinstalled macosx 10.8?

    i usually met apple logo and a grey bar when updated the firmware.
    try to restart without any connected external drives.
    when the HD gone wrong you cannot use recovery HD 'cause it is on the same disk.
    you cannot use the original install disk 'cause they are snow leopard disks.
    try to repair the internal Macintosh HD with the internet recovery disk utility function.
    if it can be repaired you can install ML.

    you can connect your iMac with the Mac mini if it has firewire800 and you can boot up the iMac in target disk mode by pressing down t while booting.
    on the desktop of your Mac mini you should see the iMac HD.
    you can repair the disk with the Mac mini's disk utility.
    hopefully you have ML installed on the Mac mini two.
    if you have installed ML on a HFS+ GUID partitioned external HD you should be able to startup properly by pressing down alt and choosing 10.8 on the external disk.
    after you have started your iMac you should see the iMac's Macintosh HD on the desktop and the external boot drive.
    try to repair it with the external drive using disk utility.
    if you have the disk doctor software you can use it to repair.
    If your internal drive cannot be mounted by osx or the repair was unsuccessfull you should consider that it is probably damaged.
    electronic problems can be solved by replacing the HD electronics with exactly the same type one.
    the disks and the reader/writer heads are in vacuum in the HD they cannot be repaired as far as i know.
    to change the HD you have to tear down half of your machine. it is not a light job to do..it is better done by a qualified professional.
     
  15. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #15
    Thanks everyone for the help - I am back in business!

    Evidently, both drives got corrupted (possibly during an update or something). This is what I ended up doing to get everything back up and running again:

    - Formatted my external drive on my Windows machine (because I could not get it to erase in Recovery on my iMac).

    - Hooked it back up to my iMac and formatted it again (this time it worked).

    - Used Internet Recovery to install Mountain Lion on the external drive (because it still would not format the internal Macintosh HD drive).

    - Booted into Mountain Lion on the external drive. Got an error saying Macintosh HD could not be repaired. It still showed up in Finder, but many of the folders had red minus signs next to them and could not be read.

    - Used Disk Utility to format my internal drive (which worked now) with a zero write option. After quite a few hours, I booted back into Internet Recovery and installed Mountain Lion back onto my internal drive.

    Now everything is working fine. I have a clean installation of Mountain Lion (which I should have done long ago anyway) and both the internal and external drives are both working properly. I don't think there's was anything physically wrong with either drive, but there must have been a bad update or backup gone wrong or something...

    I didn't actually lose much data at all because I had redundant backups of almost everything. Of course, I have to reinstall all of my software and get all of my accounts back up again, but that's not too difficult.

    THanks again for the help, and hopefully this doesn't happen again! I know now not to rely on Time Machine since it was corrupted as well. I will do the clone method from now on.
     

Share This Page