iMac wont boot :(

monty77

macrumors 6502a
Original poster
Mar 4, 2005
591
167
UK, South Coast
....boots to just before login screen then just sits there with blank screen - is there some kind of safe mode I can boot to??? Any recovery tricks? 1st time I've had OSX choke on me, thank heavens for dual boot!!!

Thanks,
Adam
 

hob

macrumors 68010
Oct 4, 2003
2,004
0
London, UK
monty77 said:
....boots to just before login screen then just sits there with blank screen - is there some kind of safe mode I can boot to??? Any recovery tricks? 1st time I've had OSX choke on me, thank heavens for dual boot!!!

Thanks,
Adam
There's several threads about this already. It's to do with the latest software update. I don't know why, but it's the most surprising thing my mac's ever done - and hopefully not a sign for the future when it comes to intel macs!

Turn the iMac on, and hold the shift key till the spinny logo comes up under the apple logo.

This will do a "Safe Boot". you'll get to the login screen, which should say "Safe Boot" in red.

Next, open System Preferences->Accounts->Startup Items and remove all the startup items. Then go to Macintosh HD/Library/StartupItems and trash that (then empty the trash).

So now StartupItems for your Account and your Library should be empty and trashed.

Restart.

This should fix it fine!

Perhaps I forgot to trash them, but the first time I tried this, I think the StartupItems folder may have un-emptied itself. If you're still having trouble booting normally, you may want to try safe booting again and re-deleting the folders.

Good luck!
 

monty77

macrumors 6502a
Original poster
Mar 4, 2005
591
167
UK, South Coast
hob said:
There's several threads about this already. It's to do with the latest software update. I don't know why, but it's the most surprising thing my mac's ever done - and hopefully not a sign for the future when it comes to intel macs!

Turn the iMac on, and hold the shift key till the spinny logo comes up under the apple logo.

This will do a "Safe Boot". you'll get to the login screen, which should say "Safe Boot" in red.

Next, open System Preferences->Accounts->Startup Items and remove all the startup items. Then go to Macintosh HD/Library/StartupItems and trash that (then empty the trash).

So now StartupItems for your Account and your Library should be empty and trashed.

Restart.

This should fix it fine!

Perhaps I forgot to trash them, but the first time I tried this, I think the StartupItems folder may have un-emptied itself. If you're still having trouble booting normally, you may want to try safe booting again and re-deleting the folders.

Good luck!
Worked a charm, thanks!!! First time my Mac has not booted and it wasn't nice ...

Cheers,
Adam
 

disconap

macrumors 68000
Oct 29, 2005
1,800
2
Portland, OR
It's a bit strange. I've used Macs for over a decade now, and this is the first time anything other than flat out hardware failure has caused my mac not to boot.

Let's see now: intel processors? Check. Ability to boot into Windows? Check. An Apple approved system update causing boot failures? Check. Looks like the journey to the dark side is almost complete...
 

tombarnes

macrumors 6502
Feb 26, 2006
345
0
Surrey, United Kingdom
I had exactly the same problem, and also after updating to the latest software updates.

There is an artical about it on the apple website. http://www.apple.com/au/support/mac101/help/2/. It seems to be a common problem through the last two OS X releases (10.3 and 10.4).

The startup item I discovered was causing the problem was Adobe VersionCue (bundled with CS2) and this has never worked properly on my intel mac, as it is not universal, I wonder if that has anything to do with it???

Cheers