iMac won't eject disc! Force eject not working!

Discussion in 'iMac' started by aaron.lee2006, Mar 24, 2007.

  1. aaron.lee2006 macrumors 65816


    Feb 23, 2006
    Ontario, Canada
    My brothers friend's iMac won't eject the disc. It locked up the computer and now it won't boot. They have tried holding down the mouse on start up but with no luck. Any thoughts?
  2. BigPrince macrumors 68020

    Dec 27, 2006
    Your are plagued by problems....

    Not sure why it wont boot. Try holding down the option key to see what you can boot off of incase it keeps trying to boot of the CD and can't move past that.

    If you can boot off the harddrive, boot of that and try using the eject key again after a restart. If it mounts, drag it to the trash.

    At my work once we were unable to get the CD to eject for the life of us after trying to install XP via boot camp. Our slip stream was stuck. We had to send it in for it to be repaired.
  3. TheAnswer macrumors 68030


    Jan 25, 2002
    Orange County, CA
    Here's a post from another thread that might help:

    Now it's important that you proceed cautiously and make sure you find the instructions kaya21(or similar) found on how exactly to do this (try google) don't want to end up damaging the drive or the disc.
  4. Mattydj macrumors regular

    Feb 14, 2007
    United Kingdom
    Try the credit card in drive approach to try and get it out. If that fails i'm sure the apple store will do it for you ;)
  5. radakaal macrumors newbie

    Sep 12, 2006
    I had an old imac that wouldn't eject the disk. I took a blank cd and gently inserted it into the slot along with the stuck cd. When I moved it around a little I was able to coax the stuck disk to move toward the opening.
  6. k2k koos macrumors 6502a

    k2k koos

    Jan 21, 2003
    Somewhere between yesterday and tomorrow
    ejecting stuck CD's

    the good old Mac trick was to use a paperclip...
    There used to be a tiny hole next to the CD slot, in which you could insert this.
    I've found ever since the "original 2nd gen iMac" (1st gen slot loading), where this hole was no longer present, but a paper clip still workes in the very outer corner of the slot.

  7. aaron.lee2006 thread starter macrumors 65816


    Feb 23, 2006
    Ontario, Canada
    Turned out to be a broken drive. It is being repaired. Thanks anyway guys.
  8. aasbur21 macrumors newbie

    Jul 30, 2008
    Credit Card

    I was really hesitant to push a credit card in there but i put it in there about 1/2 way and the disk recognized a moment later. I wouldn't just shove it on in there but if you carefully adjust the CD it may work for you.
  9. Apple Ink macrumors 68000

    Apple Ink

    Mar 7, 2008
    A sureshot remedy for the CD!
    Re boot (if you can manage that) and press 'c' The iMac should throw it out (if its not a bootable disk)
  10. Bruca macrumors newbie

    Aug 2, 2008
    ejecting iMac disc

    I recently had this experience too...with a Windows disc. None of the previous suggestions worked for me. Rebooting would result in a white screen and a whirring sound from the disc drive - and nothing else! Finally - out of desperation I took a new CD and slid it gently into the disc drive slot on the side of the iMac - just a little ways in, about an inch or so, and PRESTO - my iMac ejected the stuck disc and booted up like nothing was wrong. Hope this helps someone.
  11. sleez22 macrumors newbie

    Feb 8, 2009
    here is a tip that worked for me, in case someone else stumbles on this thread looking for options;

    i had this problem tonight, tried everything on apple/support, no work!!!

    called support, the first thing he suggested worked, apparently a secret i haven't seen anywhere else!!! i searched for two freakin' hours, and 5 minutes on the phone worked!!!

    shut computer down, while holding the eject button on the wireless keyboard, turn computer on, eject as designed!!!

    i tried at least 5 other suggestions at least twice each to no avail before this.

    2008 intel based imac


    dragging icon to trash can. NO GO
    ejecting from itunes. NO GO
    eject via disc util. NO GO (gave message "unable to unmount", with no clue what to do!)
    reboot while holding Opt-Comm-O-F. NO GO
    eject in terminal. NO GO
  12. harry454 macrumors 6502

    Sep 13, 2007
    I had this problem as well, disc got stuck, and finally got it ejected, then tried another disk, that got stuck and all scratched. Finally, had to get my drive replaced under applecare, they pu new drive in, at my house onsite, and that drive had same problem, so they ordered another one, which is running perfectly fine right now for about 6 months.
  13. longball11 macrumors 6502a


    Feb 3, 2009
    Use the force! May the force not be with you!!!! AHHHHHHHHHHH (zoom zoom) (cut in half the iMac).
  14. yaip macrumors newbie

    Feb 11, 2009
    I have a wired one. didn't work. may i have a bad drive.
  15. namikohawaii macrumors newbie

    Jul 11, 2009
    Thank You, Thank You, Thank You!

    I was starting to panic because I could not get a stupid CD out of my brand-new iMac drive for the life of me!!! I had tried every option on Apple support and other tricks people had posted on forums, and was just about to cry when I came across your posting... it actually WORKED! My mac would not restart, so I shut it down manually by holding the power button, then when it shut down, let it rest a few seconds before starting it up again. TIP: As soon as you hear the start-up sound, hold down the function key (fn) along with the eject symbol key on the top right corner of the keyboard until... voila!!! It spits it right out! Hooray!!! :D:D:D:D:D
  16. jimbuchan1 macrumors newbie

    Aug 28, 2009

    I've tried all of the above on my G5 iMac intel and it still won't eject the disk.
    I see that the use of the firmware as a means of ejecting will not work on an intel machine.
    Has any one any other suggestions or is it an 80 KM trip to a tech?
  17. Samarra macrumors newbie

    Sep 2, 2009
    Thank You!!!

    Thank you to the person who suggested the paperclip.

    I tried everything else and when putting the paper clip in the top right hand corner of the slot i got nothing but i gently jabbed the clip in and out just inside the right hand side of the slot while moving down and the disk ejected!!!!

    HA HA HA - does that sound dirty to anyone else??!!!!

    But a HUGE thank you to the suggestor of that!!! I registered purely to give my gratitude!!

    Have a freaking AWESOME DAY!!!!
  18. blaisedinsd macrumors newbie

    Nov 1, 2009
    Apple Store no Help

    I have been having this issue intermittently with my iMac since I first got it Dec 2007. I took it to the Apple Store 3 times...they saw the issue...but eventually they got it to work. I complained that just because it started working did not mean the issue was fixed and asked them to replace the drive. The last time I took it in they kept it a bit longer (I had exhaustively provided details of the issue and the history of bringing it in), then when I went to pick it up I asked them what they had done to fix it. They didn't know and I had to wait about 40 minutes for them to find the guy who had worked on it to ask him. He says he tested it and it worked so he did nothing to it. I was pretty pissed...they had my computer for days...after me bringing it in several times for the same issue I had demonstrated for their "Genius" at least twice....and then they try to give me back my computer with out even telling me they did nothing to it so that I would think they had fixed it? I am still having this issue right now.....Really lame Apple.:mad:
  19. mcduffk69 macrumors newbie

    Nov 27, 2009
    Thanks a ton! This worked perfectly. I had to hold the eject button down longer then I supposed, but it worked fine. I didn't have a wireless keyboard and it still worked. Again Thanks!! :D
  20. bb_mac macrumors newbie

    Jul 22, 2005
  21. Paul1983 macrumors newbie

    Dec 14, 2009
    Thanks so much for this! It actually worked on the first try! I was having a freaking panic attack!
  22. abarrett macrumors newbie

    Sep 5, 2006

    Brilliant!!!!!!!! Nothing else worked but the post above did!!!!!

    I was trying to load Windows on bootcamp but the mac didn't like the format and so every time I booted I got a message asking for a boot disc but it would eject the disc inside. Holding down eject on power down and powering up with eject still depressed then ejected the DVD.
  23. xscarfie macrumors newbie

    May 24, 2010
    thank-you so much!! this worked for me on the first try too, registered 5min ago just so that I could say thanks!

    YOU ROCK!! :D

    I have a 2009 intel-based mac, so firmware method also not an option for me, but this worked perfectly. Had tried absolutely everything else and was about to give in and take it in to the shop tomorrow. Thanks again!

    p.s. just to be crystal clear, in my case i shut down the computer, then let it sit for about a minute. Next, while holding down the eject button, turned it back on (holding eject button down the whole time). CD shot out like magic! :)
  24. 152coop macrumors newbie

    May 25, 2010
    Newmarket, Ontario
    This one worked for me....tried all the others and it just popped right out....thanks very much for the post....

  25. Rawn macrumors newbie

    May 26, 2010
    I've just run into a problem where I put a disc in, it made a crazy noise, then got stuck. :\

    The disc wouldn't eject, and then after I tried to eject it, it decided not to mount either. I tried the reset SMC trick, and it mounted when I turned the computer back on and I was then able to eject. So I put in another disc, as a test, and it's now stuck too/won't mount. I don't really want to reset the SMC everytime this happens, any other ideas?

Share This Page