iMac wont Mount External Firewire Drive

Discussion in 'Mac Basics and Help' started by adnan88, Oct 10, 2008.

  1. adnan88 macrumors newbie

    Joined:
    Jul 10, 2008
    #1
    I had this drive for like 8 months now, its running over Firewire 800 and it all worked perfectly up to now. Like 2 days ago the drive wont mount anymore over firewire. I thought it fried and hooked it up through USB and it works perfectly. I remember like 3 months ago I had the same problem so I unplugged everything from the iMac in the back and let it sit there for 5 mins and then it was fine. I tried doing this like 2 times already and nothing, it still wont mount. The disk doesnt show up in Disk Utilities or anything.

    This is my time machine back up drive, and I need to back up ASAP. I dont know what to do. Some are saying I must format my drive all over again. Do you guys know what I should do. I checked to see if my iMac updated and it showed one update on oct 5th, I dunno if this caused it. I updated the OSX today and still nothing happened. Any help would be appreciated. Thanks guys!
     
  2. Cave Man macrumors 604

    Cave Man

    #2
    If it's working by USB, then just use that. No need for FW for TimeMachine (although it is nicer). But the long of it is, it sounds like your enclosure's controller is failing. Probably ought to buy a new one and transport the drive into it. Do you know if the drive is PATA or SATA?
     
  3. adnan88 thread starter macrumors newbie

    Joined:
    Jul 10, 2008
    #3
    yea but I dont use my HDD only for time machine, I back up a lot of movies to it as well, and tv shows. The transfer speed on a USB compared to Firewire 800 is terrible... ...The HDD has 2 firewire inputs in the back, I tried both and both dont want to work...I hope its not the HDD itself that would really suck. I think its a SATA drive.

    I just hooked it up over firewire 400 and it works, could it be that the cable is bad for FW 800?
     
  4. hughvane macrumors 6502

    hughvane

    Joined:
    Aug 25, 2008
    Location:
    Banks Peninsula, New Zealand
    #4
    Try a new FW800 cable, not expensive, and it eliminates that as a possible cause of the problem. I guess you've probably tried it already, but swap the ends of the existing cable.
     

Share This Page