iMac won't recognize 2nd Gen iPod Touch

Discussion in 'iPod touch' started by mcdavid1, Sep 21, 2010.

  1. mcdavid1 macrumors newbie

    Joined:
    Mar 22, 2010
    #1
    I just had the hard drive of my 27" iMac 2.8 GHz Intel Core i7 replaced by my local Apple store (original drive died after only eight or so months). After a successful Time Machine restore I connected my 2nd Gen iPod Touch, and... nothing. No automatic iTunes launch, and after a manual iTunes launch, no recognition of the iPod. The iPod does show it's charging, and I've connected the same iPod to my Mac at work (works fine there). I reset the iPod just to be sure, but it made no difference.

    It seems that either something is missing in my new set-up, or some setting needs to be changed, but... what? I'm totally baffled what to do next. Everything else about my restore seems to be working perfectly, this is the only glitch (so far). Any suggestions?

    Thanks!
     
  2. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #2
    Does the iPod even start charging when you plug it in?

    I'm concerned that something may have happened inside the iMac during the hard drive replacement, which may be preventing the USB port(s) from working. Have you tried plugging something other than your iPod into the same USB port on your iMac to see if the port itself is dead?

    -- Nathan
     
  3. mcdavid1 thread starter macrumors newbie

    Joined:
    Mar 22, 2010
    #3
    Yes, it charges, but iTunes does not recognize/mount it and no syncing of apps occurs. I've tried plugging the iPod into multiple USB ports as well as to an additional USB hub. Also, several peripherals -- keyboard, trackball, etc. -- are plugged into the iMac's USB ports and all are functioning properly.
     
  4. Ivan P macrumors 68030

    Ivan P

    Joined:
    Jan 17, 2008
    Location:
    Home
    #4
    Try reinstalling iTunes. I've had this issue a few times, and apparently it's to do with the Apple Mobile Device software not initiating properly and not talking with iTunes. Reinstalling fixed it for me.
     
  5. mcdavid1 thread starter macrumors newbie

    Joined:
    Mar 22, 2010
    #5
    Thanks for the suggestions. Reinstalling seemed to make the most sense, so I tried that... twice. In between reinstalls of 10 I also tried to go backward to the last version I know worked (9), but that failed because the iTunes database capatibility had already been upconverted to 10.

    So, I've reinstalled iTunes 10 twice, with no iPod appearing in the menu. Any other suggestions? please?
     
  6. stevo101 macrumors member

    Joined:
    Oct 12, 2009
    #6
    upgrade your ipod?
     

Share This Page