iMac won't right click with ANY mouse (secondary click IS set)

Discussion in 'iMac' started by J.C, Oct 11, 2012.

  1. J.C macrumors 6502

    Joined:
    Nov 12, 2008
    #1
    Hi guys

    I'm posting this in the iMac forum and not the peripherals forum as the problem occurs with all mice so isn't related to the mouse hardware specifically.

    I've just setup a second hand iMac Core 2 Duo running Lion (all up-to-date). I've gone into mouse preferences and set the right button to be the secondary function (i.e. right-click) but both buttons still do the primary click function.

    I've tried a Mighty Mouse (wired), and Mighty Mouse (Bluetooth), as well as a Dell mouse. All work fine on other Macs but won't right-click on the iMac.

    I've rebooted the machine multiple times, I've un-paired the bluetooth mouse and re-paired, plugged and unplugged the wired mice while rebooting in between.

    I've tried setting the left button to be the secondary button. Again, both buttons remain the primary.

    Here's my mouse settings.
    [​IMG]

    Any help would be much appreciated!

    Cheers.
     
  2. J.C thread starter macrumors 6502

    Joined:
    Nov 12, 2008
    #2
    Have tried all those things again, over and over all day.

    Have also done the upgrade style instal today where files, settings etc remain. Didn't fix it.

    Did a full format of the hard drive and fresh instal of Lion (also today). No dice! Still won't let the right button of any mouse do a right click even though it's set to allow it.

    I can't understand it. It's like the iMac hardware itself doesn't allow a right-click because the three different mice I've tried (wired and Bluetooth) all work fine and the OS seems to be set correctly.

    I've just sold the machine on eBay but I think I'll have to cancel the sale :(
     
  3. tech4all macrumors 68040

    tech4all

    Joined:
    Jun 13, 2004
    Location:
    NorCal
    #3
    Not sure if this still works, but Control click to see if you get a right button action. That way you'll know if OS X even is 'allowing' that function with that particular mouse.

    Back in the day when Apple has one mice, Control clicking gave you a contextual menu.

    If that works, that I'm guessing the issue lies somewhere in the mouse and/or driver.

    I know you said other mice work, but it's worth a shot. :)
     
  4. J.C thread starter macrumors 6502

    Joined:
    Nov 12, 2008
    #4
    Thanks for the reply mate. I have tested that and forgot to mention. The Control click does work.

    I've also tried repairing permissions, creating additional users, and checking the Universal Access settings for anything that might be overriding the right-click.

    All I can think to try now is a third party driver or app. If anyone can recommend anything that'd be great.
     
  5. J.C thread starter macrumors 6502

    Joined:
    Nov 12, 2008
    #5
    Stupidly I've only just noticed now that I cannot change any mouse settings on this iMac (e.g. tracking speed) using the standard or third party mouse driver.

    Is there a way to reinstall the standard driver or do something similar?
     
  6. J.C thread starter macrumors 6502

    Joined:
    Nov 12, 2008
    #6
    Deleted all the Bluetooth and HID pref files for mice and trackpads, logged out and back in, and they were rebuilt as I'd hoped, but still no change :(
     
  7. Kebabselector macrumors 68030

    Kebabselector

    Joined:
    May 25, 2007
    Location:
    Birmingham, UK
    #7
    Are you lifting your left finger up when you click right? If not try it!

    /edit I re-read your original post, I'm fairly sure you'd know the above!
     
  8. J.C thread starter macrumors 6502

    Joined:
    Nov 12, 2008
  9. J.C thread starter macrumors 6502

    Joined:
    Nov 12, 2008
    #9
    Resolved! I found an older version of Lion I'd saved from the App Store. Created another install USB drive with it and right-click works fine now. For some reason the later version of Lion just won't right-click with this iMac.
     
  10. luciddragon macrumors newbie

    Joined:
    Oct 13, 2010
    #10
    I have the exact same issue


    Hello, I have a Mac Mini with the same problem. Running mac OS 10.7.5. I really want my right click back as its slowing me down with work. Does anyone have any ideas. My settings are correct in System Prefs, and I have tested this with 3 different mice which all work perfectly on my macbook pro running snow leopard. Any suggestions? Thanks!
     

Share This Page