iMac won't sleep

Discussion in 'iMac' started by bobnlyne, May 28, 2015.

  1. bobnlyne macrumors member

    Joined:
    Jul 14, 2011
    Location:
    San Antonio
    #1
    My iMac refuses to sleep. I have tried several times resetting the Energy Saver, to include turning off the wake on network access. Whether it enters sleep after the set times, whether I command it to restart, or whether I enter a manual sleep command, it will wake up after precisely 24 seconds. If it sleeps using the preset times, it will just cycle. Sleep in 10 minutes, wake after 24 seconds, sleep after 10 minutes, etc.
    Any help out there?
    grandbob
     
  2. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Palmdale, CA
    #2
    Need more info?

    Like what iMac (21/27", CPU, RAM) and what OS version? Also, did this problem start recently after an update or new software?

    My experience with this problem ultimately was due to some USB device and/or some app not behaving properly.

    Hope this helps . . .
     
  3. Chippy99 macrumors 6502a

    Joined:
    Apr 28, 2012
    #3
    I agree with Mugwumper - probably some USB device, but it could be other things too.

    Open up a Terminal session and type "pmset -g assertions" and see if PreventSystemSleep is 1 or 0. Also PreventUserIdleSystemSleep. Then look further down to see which process(es) are listed under these headings. It will tell you what process(es) are stopping your Mac from sleeping.
     
  4. bobnlyne thread starter macrumors member

    Joined:
    Jul 14, 2011
    Location:
    San Antonio
    #4
    Whoa, this is already a lot of info.:eek:

    First off, the iMac is a 21.5" mid 2011, 2.5Ghz i5, 8 GB RAM, running 10.10.3.
    I noticed the insomnia recently, but don't know for sure when it began. I upgraded to 10.10.3 around the time it began (possibly), but like I said, I don't know for sure when it actually began.

    Mugwumper, it sounds like you had the same problem. Do know for sure what caused it, and what did you do about it?

    Chippy 99, unfortunately I am far more of a user than a tinkerer. You wrote:

    "Open up a Terminal session and type "pmset -g assertions" and see if PreventSystemSleep is 1 or 0. Also PreventUserIdleSystemSleep. Then look further down to see which process(es) are listed under these headings. It will tell you what process(es) are stopping your Mac from sleeping."

    1. How do I open up a Terminal Session?
    2. What should PreventSystemSleep be set at, 1 or 0?
    3. Will I find PreventUserIdleSystemSleep nearby? 1 or 0?
    4. If I find which processes(es) are stopping my machine from sleeping can I undo them somehow?

    Sorry if I sound totally ignorant. I'm a lot more conversant that my bride. :cool:

    Thanks so much to you. Once I know what I'm doing I'll let you know how it turns out.

    grandbob
     
  5. bobnlyne thread starter macrumors member

    Joined:
    Jul 14, 2011
    Location:
    San Antonio
    #5
    Still won't sleep

    I sent a recently installed app to the trash. Still won't sleep,

    Also, I can't find anything about how to open a Terminal Session.
     
  6. bobnlyne thread starter macrumors member

    Joined:
    Jul 14, 2011
    Location:
    San Antonio
    #6
    Not a USB device

    I forgot to mention. The only USB device I have plugged in are my hard-wired keyboard and my Time Capsule. They have been plugged in a long time and until now haven't caused a problem.
     
  7. hfg macrumors 68040

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #7
    Easiest way is to type "Terminal" into the search (magnifying glass symbol in upper right corner of screen) ... or look in the "Utilities" folder in your Applications for the Terminal app.
     
  8. bobnlyne thread starter macrumors member

    Joined:
    Jul 14, 2011
    Location:
    San Antonio
    #8
    Thanks for your help. I found the two prevent sleep lines that Chippy 99 refered to were set to "0" which is probably the way it should be, right? So that leaves nothing else to check without running a virus scan program which I don't have. Maybe if I lay hands on it. :D
     
  9. havokalien macrumors 6502a

    havokalien

    Joined:
    Apr 27, 2006
    Location:
    Kelso, Wa
    #9
    Any updates, mine just started doing this, will sleep if i put it to sleep.
     
  10. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Palmdale, CA
    #10
    Bobnlyne -

    Sorry for the late reply - been traveling, and then moved. ;^)

    As I remember, this was caused by things on a USB hub. I was especially having problems with a scanner, and once I moved it off the hub, the scanner issues went away. And then the sleep issues went away, too.

    My iMac is a bit older (mid-2010), now running 10.11.3 - also swapped out 2x2GB original RAM and added 2x8GB for a total of 20GB. Really haven't had any problems at all (hardware or software) for quite a while. I put it to sleep at night or during the day if I'm leaving, and have turned off the Energy Saver preference. So maybe I've eliminated the source of the problem?

    Havokalien -

    I also remember that external hard drives that were connected to the hub worked better when I unmounted them before I put the iMac to sleep (typically at night, but sometimes during the day if I was going to be gone for extended periods). I also then switched the drives off the hub, and then daisy-chaining them onto a specific USB or FW port on the back of the iMac.
     

Share This Page