iMac Won't Sleep

Discussion in 'iMac' started by mikey4020, Aug 22, 2009.

  1. mikey4020 macrumors regular

    Joined:
    Sep 27, 2007
    Location:
    UK
    #1
    My 2009 iMac will not go to sleep by itself. It will go to sleep when it's induced but not automatically. I have been through several Apple support documents on this issue and searched here and on Google but nothing they suggest like resetting PRAM etc works. I have been through console to see if I can find any errors and the only thing there is a couple of entries related to my Targus Bluetooth mouse. I have tried disabling and uninstalling this, updating the driver etc and it doesn't make any difference. I'm really struggling to find out what else could be causing this and would appreciate any pointers.
     
  2. trip1ex macrumors 68000

    Joined:
    Jan 10, 2008
    #2
    My 2009 iMac started doing this about 6 weeks ago. Just looked into it tonight and, after some hunting around, I fixed it.

    Found my solution in this thread.

    My printer was showing up as in-use even though not connected. Clicked Show Queue and a document was in there. I deleted the document in the queue and now my iMac sleeps automatically.

    Problem happened because I was using my printer directly via USB sometimes and other times wirelessly via Bonjour & AEBS router. And because OS/X treats each location as a separate printer each with its own queue. Since I hadn't used the printer in the AEBS location in 6 weeks, I hadn't noticed the stuck queue and it never had a chance to clear out. And dumb OS/X never cleared the "AEBS" printer as "in-use." The whole time I was printing just fine with the printer connected directly to my Mac.
     
  3. cowman007 macrumors regular

    Joined:
    Mar 17, 2007
    #3
    I have the exact same problem but I haven't resolved it and I don't think the above solution resolves it either. I have tried disconnecting my printer and the same thing happens. For mine the display just goes off but the actual computer does not fall asleep. Any solutions??
     
  4. trip1ex macrumors 68000

    Joined:
    Jan 10, 2008
    #4
    Check Printers under Sys Pref and make sure printer isn't showing up as in use even if disconnected.

    Anyway my Sleep problem came back since I last posted. It came back after I installed Snow Leopard.

    Different cause though. This time is was due to an incompatible (with SL) program attempting to start every 10 seconds.

    Go to apps/utilities and run Console. Look at your messages. Many folks are reporting programs attempting to spawn or start every 10 seconds without success. Update the program to the newest version if there is one yet.
     
  5. mikey4020 thread starter macrumors regular

    Joined:
    Sep 27, 2007
    Location:
    UK
    #5
    I've been through my printer settings and there is nothing that I can see that would prevent sleep.

    I've also been through console and the only related messages appearing relate to the program Notify which polls your Gmail for new messages. I wondered if it could be this but I've tried disabling it and I only installed it last week and had the sleep issue before then anyway.

    I had hoped it was some messed up .plist or something that would be fixed when upgrading to SL. I'm wondering whether just to backup my stuff and do a clean install of SL.
     
  6. trevis macrumors newbie

    Joined:
    Mar 14, 2008
    #6
    Try turning iMac Off, disconnect all cables and leave it like this for 5 mins.
    This procedure is called "Resetting SMC".

    http://support.apple.com/kb/HT1543

    This helped me in the same situation on Aug 2007 iMac.

    Thanks
     

Share This Page