iMac won't wake from sleep

Discussion in 'Mac OS X Lion (10.7)' started by wilfried, Oct 26, 2011.

  1. wilfried macrumors member

    Jan 9, 2008
    My iMac didn't wake up this morning. So neither did I.

    Usually when I leave my computer, I manually put it to sleep. I have a few programs that are timed to run. An alarm clock is one, EyeTV to record television programs is another. Until last week, I had no problem. At the appointed time, the iMac would wake up, sound the alarm, record the program, or whatever. As of this week it doesn't happen. I can put the computer to sleep, and I can wake it up with key presses, but it doesn't automatically wake up when it's supposed to. I think the problem began a couple of days ago when I returned from vacation. During vacation, I had the computer off and unplugged, and it hasn't behaved properly since I returned.

    A few more symptoms: I'm not sure it's going to sleep properly. It used to take a few seconds for the computer go to sleep (and sometimes it took a long time, which was annoying), and I could hear clicks, I think from the attached hard drives going to sleep. Now the computer screen goes blank instantly, but I hear no clicks. I can't tell if the computer is asleep behind the blank screen.

    I have set in Bluetooth preferences not to allow Bluetooth devices to wake up the computer (I use a Magic Mouse and I wired keyboard). Mouse clicks didn't do anything before, but now a mouse click does make the screen light up. This makes me think the computer isn't really asleep (but it's not quite awake either, as programs don't run).

    Last weirdness, I have the computer set to announce the time every half hour. When I wake the computer from sleep by hitting the keyboard, it announces the time, even if it was 20 mins. ago, and the alarm will go off, even if it's now late.

    I wasn't entirely sure where to post this; I hope it's a software problem, and I'm running Lion. I'm not sure where to begin troubleshooting. Any thoughts on what's going wrong or what to try?
  2. wilfried thread starter macrumors member

    Jan 9, 2008
    FWIW, some more symptoms:

    I've determined that my "sleeping" iMac isn't really asleep. The screen goes dark, but I can still hear fans whirring and the hard drive clicking (I have to put my ear up against the machine; these things are quiet!). Things like a Time Machine backup keep running.

    It's a software issue. I booted into an old Snow Leopard clone, and when I put it to sleep, the fans stop, and you can hear a click as the hard drive parks and stops. Boot again into Lion, and the sleep issue returns.

    I don't know if anyone has any ideas, but I can't figure this out. TIA if anyone has any suggestions.
  3. myyours, Oct 27, 2011
    Last edited: Oct 27, 2011

    myyours macrumors newbie

    Jun 5, 2008
    Sorry wilfried, I can't help, but just wanted to piggyback onto this to say that something similar is happening to me too.

    I have my Energy Saver preferences set to wake the computer up every morning at 7 am...and then I have an automator/iCal action that plays an iTunes playlist at 7:05. This worked like a charm for months, and then suddenly about a month ago, it stopped (oddly, but totally coincidentally, after I returned from a vacation). One of two things "happens." Either nothing happens, or the iTunes playlist starts playing 10 or 20 minutes after it was supposed to (after something else apparently wakes the computer up).

    I can't directly attribute this new misbehavior to anything in particular. It worked under Lion for at least a month, so Lion didn't break it. And it worked for at least a couple days under 10.7.2.

    I'm yet to really study if it ever actually goes to sleep, so can't add anything to that side of things.

    As a farfetched aside, my ethernet port is dead, so I'm not sure if that could somehow contribute to the problem.

    2010 iMac, 3.5 GHz, Intel Core i5, 10.7.2
  4. wilfried, Oct 27, 2011
    Last edited: Oct 27, 2011

    wilfried thread starter macrumors member

    Jan 9, 2008
    FWIW, after much ado, much Internet surfing, and a call to Applecare (who couldn't help), I figured it out. A random post somewhere on the web led me to the answer.

    There was a print job stuck in my print cue; I don't even have a printer (not a working one, anyway). In case this helps anyone, go to System Preferences > Print & Scan > Open Print Cue. Delete whatever jobs are there, and voilà, problem solved... at least in this case.
  5. myyours macrumors newbie

    Jun 5, 2008
    And mine was solved with a new logic board, FWIW.

Share This Page