Imac wont wake up from sleep?

Discussion in 'iMac' started by vexbegone, Jun 11, 2015.

  1. vexbegone macrumors newbie

    Joined:
    Dec 30, 2014
    #1
    Over the last few days, i put my Imac to sleep in the evening. When i try and wake it with my keyboard or mouse, it no longer wakes up. I have to press the power button to wake it, then a bar appears at the bottom of the screen loading, while i can see my background. I have a Late 2013 27 inch Imac. Maybe this is nothing to worry about but some feedback would be great. Thanks.
     
  2. dspalton macrumors 6502a

    Joined:
    Jul 28, 2008
    Location:
    Fleet, UK
    #2
    Ive got a late 2013 21inch iMac
    Keyboard and Mouse disconnect for whatever reason when it sleeps and don't reconnect when trying to wake up.
    Batteries brand new

    Dave
     
  3. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
    #3
    Did you recently add memory? If so, where they Crucial chips?
     
  4. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #4
    Have you tried kissing it?

    Works in the movies
     
  5. vexbegone thread starter macrumors newbie

    Joined:
    Dec 30, 2014
    #5
    I am having that exact problem as well. I haven't added new memory. Ill try kissing it when i get home, maybe a glass of wine will help.
     
  6. dspalton macrumors 6502a

    Joined:
    Jul 28, 2008
    Location:
    Fleet, UK
    #6
    Same here, no new memory added.
    Are you on same Device? (late 13 iMac)
     
  7. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #7
    If your iMac have a mechanical HDD, the progress bar can indicate your machine is waking from "Safe Sleep," and the situation you describe would be normal. Per https://support.apple.com/en-us/HT202824
    If it's not Safe Sleep, this is the go-to support article: https://support.apple.com/en-us/HT204760 - skip down to "Your computer can't wake from sleep."
     
  8. vexbegone thread starter macrumors newbie

    Joined:
    Dec 30, 2014
    #8
    Thanks! I just reset my NVRAM so hopefully that fixed it. I will post back with an update in a day or so.
     
  9. dspalton macrumors 6502a

    Joined:
    Jul 28, 2008
    Location:
    Fleet, UK
    #9
    I did the NVRAM reset with apple support a few days ago.
    It worked for about 24 hours.

    I think it's an on going issue now. Bit crap
    :(
     
  10. jcooper131, Jun 12, 2015
    Last edited: Jun 12, 2015

    jcooper131 macrumors newbie

    Joined:
    Jun 12, 2015
    #10
    I am having the same problem. I installed new memory 2 days ago. I have a mid 2011 27in iMac.

    Any suggestions?
     
  11. bokat57, Jun 12, 2015
    Last edited: Jun 12, 2015

    bokat57 macrumors newbie

    Joined:
    Jun 12, 2015
    #11
    Hi
    I had the exact same problem with my late 2012 iMac. After much confusion with apple "genius" staff and apple care I found the fix on the internet.

    That safe sleep stuff is for the laptops an iMac as it is always plugged in does not need it. Some how the setting that controls it got changed on my mac. To turn off safe sleep and have it sleep normally open the terminal and copy and paste the following commands into your terminal one at a time :



    sudo pmset -a autopoweroffdelay 86400

    sudo pmset -a autopoweroff 0

    If you are not familiar with the terminal let me know and I will walk you through it
     
  12. jcooper131 macrumors newbie

    Joined:
    Jun 12, 2015
    #12
    Thank you. I am not familiar with terminal. I haven't needed to use it yet.
     
  13. bokat57, Jun 12, 2015
    Last edited: Jun 12, 2015

    bokat57 macrumors newbie

    Joined:
    Jun 12, 2015
    #13
    Hi

    Step 1 open the terminal app. the path to the terminal app. is : Applications/Utilities

    Step 2 type sudo -s at the prompt and press enter then enter the administer password ( when you type in the password you won't see it this is normal) after you have entered the password press enter

    Step 3 copy and paste sudo pmset -a autopoweroffdelay 86400 in the terminal at the prompt then press enter

    Step 4 copy and paste sudo pmset -a autopoweroff 0 in the terminal at the prompt then press enter

    Step 5 Quit the terminal

    You should be good to go ! if you have any questions please feel free to contact me

    Good Luck !
    Bob
     
  14. dspalton macrumors 6502a

    Joined:
    Jul 28, 2008
    Location:
    Fleet, UK
    #14
    Still not having any luck with this...
    have done the above
     

Share This Page