iMac wont wirelessly connect unless Ethernet cable plugged in

Discussion in 'iMac' started by rocketjacket, Apr 26, 2013.

  1. rocketjacket macrumors member

    Joined:
    Jul 5, 2012
    #1
    A Mid 2011 iMac with 10.8.3

    Router is a Belkin N600 Duel band


    iPad, iPhone connect wireless fine, the iMac wont connect.
    The Wireless icon on the iMac continues to have an explanation point through it.

    But if I plug in an ethernet cable directly from the router to the iMac, the wireless connection works fine.

    I have created a new wireless connection in the Network Prefs....no good

    I have turned off the security on the router....Still not good.

    Any ideas?
     
  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    Try moving (Not deleting yet) this Folder:

    /Library/Preferences/SystemConfiguration

    After you moved it restart, you need to restart otherwise the System still reads from that folder.

    All network settings are in this Folder, after a reset all network settings are set to default.

    If this didn't work you could drag the folder back into its place.

    Your ?Library Folder is invisible by default, you can go there by clicking on the go menu in Finder, then Go to Folder, enter /Library in the box and hit Enter.
     
  3. rocketjacket thread starter macrumors member

    Joined:
    Jul 5, 2012
  4. Serban Suspended

    Joined:
    Jan 8, 2013
    #4
    Hi,
    try this: delete all the networks from wifi advanced. Change the name,channel number, and the password wpa2 of your net. Turn wifi off then on, if you don't see your wifi name select other and you are good to go
     
  5. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #5
    Wired Ethernet is always preferred if you can run the cable.
     
  6. Nuke61 macrumors 6502

    Joined:
    Jan 18, 2013
    Location:
    Columbia, SC
    #6
    It may sound odd, but in your wireless PASSWORD box, put "0x" before your password and try it. That seemingly odd fix has been reported to work in many cases where wireless will not connect. It's because your router may be expecting the password as a Hex string, or maybe nothing will change, but it's worth a try.
     

Share This Page