iMac wouldn't turn on

Discussion in 'iMac' started by aonelas, Nov 28, 2010.

  1. aonelas macrumors newbie

    Joined:
    Nov 14, 2010
    Location:
    Honolulu
    #1
    I've had this computer for about ten days or so. Also, I found an 08 thread similar to this that I'm about to post, except there was no resolution.

    It was sleep for about an hour, maybe, when I came over here to use it. I pressed a key on the board.. nothing happened. I pressed it again. Still no response. So I started pressing lots of keys simultaneously... nothing. I checked the keyboard power, it was good. Played with the mouse some, checked that it was on as well. Then I figured maybe some update got pushed to it and it shut down (I'm not too familiar with the way apple does those things yet). So I pressed the power button on the back.. nothing. Pressed it again.. nothing. Finally, I disconnected and reconnected the power. Pressed the button again, and it came on.

    From internet searches, I've seen that a few people have had this problem with older machines, but I saw no causes. Anyone got ideas or similar experiences? Is there something I can do to prevent this from happening - it is not at all okay?

    Something else, I tried overwriting a file, and I got an error message telling me I didn't have the permissions necessary to do it.

    This is a new machine, 27" i3

    Thanks for any help :)!
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Could have been electricity pause or something. I wouldn't worry unless it happens again
     

Share This Page