iMacs changing time BACK 5 mins randomly - School Computers

Discussion in 'macOS' started by neon87, Mar 10, 2008.

  1. neon87 macrumors newbie

    Joined:
    Mar 10, 2008
    #1
    Hello,

    My name is simon. Im a technician at a school in Australia and im very new to macs. We have a Mac X serve running 10.5.2, and all our clients are running 10.5.2 as well.

    We have about 30 imacs - a mix of early 2006 intel, and G5 17".
    The way we have them set up, is they are joined to the Xserve but not bound, and they are bound to active directory on our windows domain so students can log in.

    The X serve controls the docks, and settings and security, and it works well. The reason they are bound to active directory is so that we can use our active directory accounts to log the students onto them. This works very well also.

    The problem that we are having is this:

    The clients seem to randomly set the time back 5 minutes from the server time. We change it back, but when we turn them on the next day, they are back to their own time.

    I should explain that Active directory only allows log ins from computers with the correct time, and this is preventing log on.

    Now, the windows server, and the X server are the same time. We have turned OFF the time server option on the clients, so they are not getting their time from a time server. We have set it manually to the correct time, and we reboot the computers and they are fine for a day or a few hours, and seem to randomly change back.

    Does anyone know why this occours, and if there is a way to fix it?

    Thanks very much for anyone who can help.

    Kind Regards,

    Simon.
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Where are the systems getting their time?? From the XServe, From the Windows Server, or from an outside source? Does this continue when you use an external time server? Have you tried to setup the Windows server as a Time Server to solve this problem??

    TEG
     
  3. neon87 thread starter macrumors newbie

    Joined:
    Mar 10, 2008
    #3
    Thankyou so much for the quick reply TEG.

    on the image as default, they were set to get their time from the asia pacific apple time server (i forget the actual address). We have disabled that (just unticked the "get time automatically" in the time preferences panel, and set it to manual and changed it locally on the machine.

    My thought was perhaps its resetting to the bios/efi time? I'm not fluent on mac hardware, but they must have an internal clock? Does osx read from that? and does it change it if its changed in osx?

    I'm pretty sure that the time is set locally, but i cant be sure! Is there another place within OSX to set time servers etc?

    We havent made our Xserver a time server yet as im not sure how to do it, but i can confirm the time on the macserver and the windows server is the same, and both are correct time, however this time seems to be different to any other time in the school.
     

Share This Page