iMail Recovery Message just keeps multiplying!!!

Discussion in 'Mac Basics and Help' started by Icemother, Dec 9, 2011.

  1. Icemother macrumors newbie

    Joined:
    Dec 9, 2011
    #1
    Hi,

    Can anyone help me please?

    I have Recovered Message in my iMail from Gmail which just keeps multiplying.. says same time and same details.. it has 6 attachments and is now starting to take up memory as it has been "recovered" up to 91 times. Each time I open iMail it starts recovering the message all over again. I don't even remember trying to "recover" this message I sent. Very confusing and very annoying as it is taking up a lot of space and now starting to compromise my Start Up Disk. Is this a virus?

    Can anyone help with how to delete this annoying "Recovered Message" folder. Normal deleting only seems to make it multiply and doesn't work.. I am thinking of trashing my iMail! Oh btw I have removed this message from my Gmail.

    Regards and thanks, Liz
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    I've had this odd problem before. It's usually caused by composing a draft that Mail started to autosave when you hit Send, waited for the sending process to finish, then quit out of Mail. The solution is to delete both the offending draft AND the recovered messages folder Mail creates - bring up the Activity window when you do this, and wait until Mail finishes doing its thing (all activity ceases in the Activity window).

    What makes this particularly annoying is that it'll keep trying to recover the message until you manually clean up after it, as you've discovered.
     
  3. Icemother thread starter macrumors newbie

    Joined:
    Dec 9, 2011
    #3
    Thanks for the suggestion wrldwzrd89.

    I have deleted everything to do with the message and it is still multiplying.

    I would like to just uninstall iMail and maybe reinstall it, but don't know how to. I don't really use it.

    I would like to make Hotmail my default mail and don't know how to do that either.

    Now getting really frustrated as I have spent ages searching for for answers and not getting any. You were my first helpful discovery and I had already tried what you said. Thanks.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    If you want to "go nuclear" on Mail... here's what you do.
    1. Navigate to your home folder in the Finder.
    2. If on Snow Leopard or earlier open Library; if on Lion choose the Go to Folder... option in the Go menu, and enter at the prompt: ~/Library
    3. Find the Mail folder in there
    4. You may also notice another folder called Mail Downloads.
    5. Delete both of them (while Mail is NOT running), then restart Mail.

    As far as making Hotmail your default mail, enabling that depends on a variety of factors - two important ones being the version of Mac OS X you are running and which web browser you normally use.
     
  5. Icemother thread starter macrumors newbie

    Joined:
    Dec 9, 2011
    #5
    Hi again.. actually I was thinking I might delete iMail.. then in my "time capsule" I might recover it on a date before "the message" was sent and then see what happens when I retrieve mail as "the message" has now been deleted. Do you think that would work? Btw I have OS X 10.6.8
    Ciao, Liz
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    That will not work. Deleting and restoring the application itself will do nothing. However, quitting Mail, deleting its two data folders, and restoring THOSE from a Time Machine backup has a better chance of actually working.
     
  7. Icemother thread starter macrumors newbie

    Joined:
    Dec 9, 2011
    #7
    Hi again.. actually that's what I decided to do and it worked. Thanks for your input. :D Liz
     

Share This Page