iMail replying to emails from the wrong email account

Discussion in 'Mac Apps and Mac App Store' started by grholden, Mar 25, 2012.

  1. grholden macrumors newbie

    Joined:
    Dec 21, 2010
    #1
    Hi all,

    I wondered if you could offer any assistance with the following issue that I have.

    I have 3 email accounts set up in iMail: 1) my gmail personal account; 2) my work email (that runs through gmail (it is a school account, I'm a teacher); 3) my University email that is run through a Microsoft Exchange server.

    No issues with 3) at all.

    I can start messages and send from whichever account I specify, that's not an issue. However, when someone emails me to my work account (2), when I reply it looks as though it will be sent from my work email, but actually ends up going from my personal (1) email!?

    Really, really confused!

    I am using both as IMAP, does this have anything to do with it? Both are using the same port number, does that have anything to do with it?

    Thanks for any help / suggestions you can give.
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    The MacOS X bundled email client is Mail, not iMail. IMail is a Windows-based email server.

    As to your problem, it appears as though you do not have your university outgoing mail server configured properly to access it from outside your university domain. Mail falls through to a SMTP server that is properly configured, which happens to be the SMTP server for your personal account.

    My work email is also on an Exchange Server. It can be accessed outside its domain only by the Outlook Web Access webmail client. Apparently, you can access your incoming mail from outside your university domain. You need to determine if it is even possible to access outgoing mail the same way. If you can, then you need the proper configuration settings to do so. Only your university's IT staff can give you this information. That is if the university does not have a tech support web page.
     
  3. LaWally macrumors 6502a

    Joined:
    Feb 24, 2012
    #3
    I'm going to assume you mean Mac Mail.

    The problem is most likely that more than one email account is using the same Outgoing Mail Server (SMTP). To correct the problem, go to mail->preferences->accounts->accounts information->Outgoing Mail Server. Using the arrows choose "edit smtp" and assign to each account a single server, then tick at "use only this server" for each account. That should resolve the issue.

    You may also want to do an Internet search for: "multiple gmail accounts in Mac Mail" for additional info.
     
  4. grholden thread starter macrumors newbie

    Joined:
    Dec 21, 2010
    #4
    My apologies guys - I DID mean 'mail'. Thanks for responding.

    MisterMe - am a bit confused though as you seem to be suggesting that the problem lies with my University email, although as stated in my original post, that account is actually operating with no issues. Are you suggesting that THAT account is causing issues with the other ones?

    Thanks LaWally - I'll have a go and alter the settings later on when I am back from work. I think I appreciate what you're saying.
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    OK. By including extraneous information in your post, you opened it up to misinterpretation. A careful rereading of your OP indicates that you have two Gmail accounts--one personal and a second through your work. Your problem still lies with your SMTP configuration settings. LaWally's suggestion is one possible solution. I would also suggest that you switch to Authenticated SMTP which uses Port 587 rather than unauthenticated SMTP (Port 25). This requires that you check Use Secure Socket Layer and that you enter your email address and password in the appropriate boxes.

    If this does not work, then return and post your configuration settings with personal information redacted.
     
  6. grholden thread starter macrumors newbie

    Joined:
    Dec 21, 2010
    #6
    LaWally - thanks again for your help. I am a complete novice when it comes to things like this though. I understand HOW to get on to the settings that you both mention, but I am confused as to what I actually have to do to set it to another mail server.

    It seems that you're right in what you say and I took your advice about googling it - and it came up with the likes of https://discussions.apple.com/thread/3340457?start=0&tstart=0.

    MisterMe - sorry for confusing, I didn't know what was relevant what wasn't. How do I get it to automatically used Authenticated SMTP that uses port 587? I *think* I have done what you have suggested below - but am still having the same issue :(

    Thanks again for your kind responses.
     

Share This Page