imap Gmail in Mail and iPhone

Discussion in 'Mac Apps and Mac App Store' started by Testify, Mar 24, 2009.

  1. Testify macrumors member

    Joined:
    Aug 25, 2008
    #1
    Hi,

    I recently got my new iMac and i'm now trying to configure my imap gmail in mail!

    Everything is working except the fact that when I read a mail in gmail on my iPhone it doesnt mark as read in Mail.

    But, when I clode the application in OS X and re-open it, the mail changes status and is now mark as read.

    But, I open Mail at login and let it run all the time.

    Is there a way to make it change while Mail is open?? I Mroogle'd and google'd the procedure to set up imap in iphone and Mail .

    Anyone already fixed this kind of behaviour?

    Setup:

    iMac 2009
    OS X 10.5.6
    iPhone 3G on the latest OS version

    thanks!
     
  2. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #2
    How quickly are you checking in Mail, after you have checked your email on your iPhone?
     
  3. Testify thread starter macrumors member

    Joined:
    Aug 25, 2008
    #3
    I sent a mail during the afternoon at work, checked it on my iPhone a few minutes later.

    Finished my day at work, so I must have checked it on Mail couple of hours after.
     
  4. thebreadking macrumors member

    Joined:
    Nov 26, 2008
    #4
    I have the same problem with mail on my iPhone and when using the Gmail web client on other computers. Regardless of what I do, messages read or deleted on my main computer's Mail app are never marked as read or deleted on my iPhone or the web client, and vice versa when making changes on the iPhone or web client and not seeing them update in Mail.

    The iPhone and the Gmail web client play well together. Mail not acting how I assume it's supposed to makes it almost worthless to me.
     
  5. RonCarr macrumors regular

    RonCarr

    Joined:
    Sep 12, 2007
    Location:
    Tennessee
    #5
    I have Mail set up with my Gmail account as well as my iPhone and do not have a problem with them staying in sync. The default setting for Mail is to set up your Gmail as pop so be sure you tell it not to set up your account automatically and do actually put the required information in manually. Google has instructions on how to set up Mail this way. Be sure you have actually enabled imap from your Gmail settings on the web based version.
     
  6. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #6
    Sometimes I have that problem but pretty rarely as I almost always use the iPhone Mail app instead.

    When I do have that problem it's easy to fix. With the inbox highlighted go to Mailbox > Rebuild. It'll take a second and then, boom, you're synced.
     
  7. Testify thread starter macrumors member

    Joined:
    Aug 25, 2008
    #7
    Ok, thanks for the tips!

    But since yesterday seems to be working better. I think I'm not yet in a full Mac OS X mode and I forgot to quit the Mail.app to take effet my changes. The red light quite doesn't do it!

    Seems to be OK now, thanks for all the inputs!
     
  8. RonCarr macrumors regular

    RonCarr

    Joined:
    Sep 12, 2007
    Location:
    Tennessee
    #8
    Yeah I always just hit Command-Q to quit an application. It is odd to me that some programs will actually quit by hitting the red X (iPhoto) while others will not. I think it has to do with if the program can have more than one window open then the red X allows you to just close close that window without quitting the application. Oh and by the way to just close the active window it is Command-W. This works for closing the top Finder window or if you do not want to quit the program, but just close the top window.
     

Share This Page