IMAP mail server on iPhone

max2

macrumors 68030
Original poster
May 31, 2015
2,791
517
I keep getting duplicate folders and stuff when using a IMAP mail server. Anyway to prevent this ? I use Cox for my ISP.
 

Significant1

macrumors 6502a
Dec 20, 2014
708
210
I can tell my iPhone to use the IMAP folders that Cox provides and it will do so. But when I see the folder list, those default Apple IMAP folders remain.

Unless there is a way to delete the default folders off the iPhone? Or through the webmail section on Cox's website?
Sure it will not delete them automatically, but you can do it manually from the iPhone or another client. On the iPhone:
- go to mail app
- Go all the way to the top (left)
- At the bottom each account are listed, where you can access all folders each account may have
- Select the Cox account
- Click edit top right corner
- Click the folder (Apple call them mailboxes!?!) you want to delete
- Press delete at the bottom
 
  • Like
Reactions: eyoungren

eyoungren

macrumors Core
Aug 31, 2011
21,180
13,021
ten-zero-eleven-zero-zero by zero-two
Sure it will not delete them automatically, but you can do it manually from the iPhone or another client. On the iPhone:
- go to mail app
- Go all the way to the top (left)
- At the bottom each account are listed, where you can access all folders each account may have
- Select the Cox account
- Click edit top right corner
- Click the folder (Apple call them mailboxes!?!) you want to delete
- Press delete at the bottom
Hmmm…

Thanks. I didn't realize I could do that. I'm going to guess that the folders I deleted are the default Apple ones and not Cox's IMAP default folders though.

Also, even though I deleted them from the account, if I got back in to Settings>Mail, Contacts and Calendars and select my Cox account (Advanced) and look through there the folders I deleted are listed. Guess those must be the defaults.
 

Significant1

macrumors 6502a
Dec 20, 2014
708
210
Also, even though I deleted them from the account, if I got back in to Settings>Mail, Contacts and Calendars and select my Cox account (Advanced) and look through there the folders I deleted are listed. Guess those must be the defaults.
My guess is, that you deleted Apple's default folders, but that setting still gives you Apple's way as an option. I have not tested myself.
 
  • Like
Reactions: eyoungren