iMessage and airplane mode 5.1.1

Discussion in 'iOS 5 and earlier' started by prodigee, Jun 15, 2012.

  1. prodigee macrumors 6502a

    Joined:
    Sep 23, 2009
    Location:
    Brooklyn, NY
    #1
    So I've been in Sweden for a week out of 6 weeks so far. And my phone hadn't been updated for a while, so while I was bored I updated it. It was on like 5.0.1 or whatever that last update was before 5.1. And I had no issues sending or receiving iMessages in airplane mode (I'm from the US so I don't want to incur fees here, so I just text via iMessage). So after the update, all seems well until I go to my internship the next day. Change wifi networks suddenly iMessage doesn't work any more. Restart it, soft reset, plug it in to the comp blah blah blah, doesn't fix it. Take it out of airplane mode, suddenly it works. Then put it back in airplane mode, and it's fine. Then I go back to my apartment here again. BOOM same problem as earlier. So this has been going on now for 3 days, and I have no idea why. If I look at iMessage when I'm in airplane mode, it says waiting for activation... But I connect via cell network and then put it in airplane mode, it activates and does it all fine. But if I turn iMessage off after that (this I discovered while testing for reasons as to why it's not working), BOOM it goes away again.. I really don't get it... Any help would be greatly appreciated.

    Thanks guys.
     
  2. SAD*FACED*CLOWN macrumors 65816

    SAD*FACED*CLOWN

    Joined:
    Apr 5, 2010
    Location:
    Houston, TX
    #2
    is your caller id set as only a phone number? that may be the reason...make sure you can recieve at your Apple id and your cell number....I spent a month in Thailand in airplane mode and had no problems whatsoever with iMessages...or it could be the wifi you're on
     
  3. prodigee thread starter macrumors 6502a

    Joined:
    Sep 23, 2009
    Location:
    Brooklyn, NY
    #3
    Nope has the Apple ID as well.

    The wifi is no issue either... I don't get what it is.
     
  4. shurcooL macrumors 6502a

    Joined:
    Jan 24, 2011
    #4
    Strange, it should be fine. I have the latest iOS and I was able to use iMessage just fine in Airplane mode (I too was travelling). The only problem was a slightly annoying popup telling me I can't send SMSes while in Airplane mode (duh, and that's good, cuz I want to send iMessages only).
     
  5. sharkmok macrumors newbie

    Joined:
    Mar 8, 2012
    #5
    I think this is how it works. iMessage use SMS to activate. So, if you are in airplane mode, even with wifi, iMessage cannot be activated. If you tune on cell network, iMessage can sent out the activation SMS to get iMessage activated. Once it is activated, you can stay on wifi and still get iMessage to work. But every time you turn iMessage off and on again, it needs to be activated again.
    Since you've done the update, iMessage needs to be re-activated again and sms must be working for it to activate.
    The key is to make sure iMessage does not need to be re-activated any time if you don't want to be on cell network.
     
  6. prodigee thread starter macrumors 6502a

    Joined:
    Sep 23, 2009
    Location:
    Brooklyn, NY
    #6
    That would make sense...Except for the fact that iPads and iPods use the same system, so it shouldn't matter. AND it was working fine before the update. So I'm confident it was something then that caused it. And I have connected to cell networks a few times (as I said in the first post) and iMessage activates, and I still have the problem...
     
  7. prodigee thread starter macrumors 6502a

    Joined:
    Sep 23, 2009
    Location:
    Brooklyn, NY
  8. SD2SF macrumors newbie

    Joined:
    Jul 3, 2012
    #8
    This worked for me

    Hi there,

    I'm in India and had the same problem with iMessage not sending messages while in Airplane mode and whilst connected to WiFi. I searched around and got to this forum: http://appletoolbox.com/2011/10/ios-5-imessage-not-working-–-how-to-fix/.

    This worked for me and hopefully it will work for you, but you'll have to go into the WiFi network's settings and change the DNS server IP to 8.8.8.8. It worked after the first try! I'd be curious to know if this worked for you too.

    Good luck.
     

Share This Page