iMessage and Airplane mode question

Discussion in 'iOS 6' started by blueorchid, Nov 19, 2012.

  1. blueorchid macrumors newbie

    Nov 19, 2012
    If I am on airplane mode with no wifi... I shouldn't be able to get iMessages or Texts until I turn off airplane mode right?

    What if someone with an iPhone sends iMessages to should revert to Text since I don't have iMessage turned on. I should be able to get the Text they sent when I turn off airplane mode. But I don't! I only get texts from people who send texts... but I don't receive the iMessages that have reverted to Text (after I turn off airplane mode).

    Anyone else have this problem???
  2. Gav2k macrumors G3


    Jul 24, 2009
    I find the opposite. If my phones in airplane mode iMessages still come through after airplane mode is turned off.
  3. Dwalls90 macrumors 601


    Feb 5, 2009
    When you're phone has airplane mode enabled it drops off the radar. So you may have to give it up to a few hours, whenever the carrier pushes the message through ... it's a limitation of SMS not iMessage.

    Also, from my experience, my phone will only send an iMessage instead of a text message, if I SELECT it to, after the iMessage fails to go through. Are you sure the other party is overriding it to go through as a SMS, after it's failing to go through as an iMessage?

    Are you also sure that you don't have iMessage enabled on another device? Sometimes I've encountered that if my phones off the grid, the iMessage will get delivered to those other devices and it will "forgot" my iPhone in the mean time.
  4. blueorchid thread starter macrumors newbie

    Nov 19, 2012
    I guess I'm not for sure if they send it thru as iMessage or Text still when I'm on Airplane Mode. But I never get the message regardless, when my airplane mode turns off. I tried turning on/off my phone and on/off iMsg...but never get the messages.

    But in the past, when I sent an iMsg to someone else and they were on Airplane mode, it sent as Text. They never received my iMsg/Text. But I think this is because I have "Send as SMS if iMessage not avalable" on. Not sure if this has anything to do with it.

    It's confusing. I don't want to turn on airplane mode now, b/c I may not receive messages.

Share This Page