iMessage and Android problem

Discussion in 'Alternatives to iOS and iOS Devices' started by strausd, Dec 21, 2012.

  1. strausd macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #1
    Finally got my replacement Nexus 4. But now when any iPhone sends me a text, it automatically sends it through iMessage. And I get it on my iPad, but not at all on my Nexus 4. I turned iMessage off on my old iPhone I was using, but that didn't fix it. Now whenever someone sends me a message from an iPhone, I won't get it on my phone unless they tap on hold on EVERY message they want me to get and click "send as text message." Is there any better way to do it? Having to remember to tap each message and tell it to send as a text can get very annoying.
     
  2. nospleen macrumors 68020

    nospleen

    Joined:
    Dec 8, 2002
    Location:
    Texas
    #2
    I had this same issue and what worked for me you referenced above. Just make sure you sign out first and then turn off. I tried turning off first and that didn't work.
     
  3. tbayrgs macrumors 603

    tbayrgs

    Joined:
    Jul 5, 2009
    Location:
    Florida, USA
    #3
    Same problem for me as well when I switched from an iPhone to my Nexus 4. I had also set up my iPad and Mac to received iMessages sent to my iPhone cell number so I had to remove that number from all other devices in addition to disabling iMessage on my iPhone. Once that was done I was good.

    Oh, also to be safe I removed my cell number from my profile for my Apple ID on Apple's website after reading various forums stating it was necessary to remove your cell number from your Apple ID.
     
  4. strausd thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #4
    How would I delete my number from my iPad and MBP?
     
  5. tbayrgs macrumors 603

    tbayrgs

    Joined:
    Jul 5, 2009
    Location:
    Florida, USA
    #5
    Here's the response I gave to someone else with the same problem in another thread.
     
  6. strausd thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #6
    Thank you for that. I will actually be using my iPhone for another week so I will try this when I am able to get back on my Nexus 4.
     
  7. strausd thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #7
    So I took minute to see if that option is on my iPad, but its not. However, I am still receiving iMessages on my iPad. The only thing showing up is my email address and not my phone number. And when I clicked on my email address and tapped "view account." Unfortunately, I get a server error every time I tap that. I'm on 6.0.1 on my iPad and my iPhone is on 5.1.1 I think.
     
  8. MRU, Dec 22, 2012
    Last edited: Dec 22, 2012

    MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Other
    #8
    Turn it off on your iPad too. Your telephone number and apple ID are linked together at the moment. Turning off iMessage or severing the link between your number and your iD is only way to stop this.

    One solution

    Go to Settings - Mail, contacts, calendar - My info and select from contact list and make sure your number isn't on that.
     
  9. tbayrgs macrumors 603

    tbayrgs

    Joined:
    Jul 5, 2009
    Location:
    Florida, USA
    #9
    And you're positive they're actually not being sent to your email address (vs. your phone number)?

    ----------

    I found just turning off iMessage wasn't enough--did that first on both my iPad and Mac but still wasn't receiving text messages from iPhones. Only after I removed the telephone number from both devices did I start getting text messages again. If you Stausd doesn't see his phone number listed under Send & Receive options in Messages on his iPad or under Preferences (Messages > Preferences > Accounts) on his MBP, not sure where else to look.

    You should have to remove your number from your contacts--I still have mine included on my contact card on all my devices.
     
  10. strausd thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #10
    I'd like for it to still be sent to my email address.

    Positive.
     
  11. cheezeit macrumors 6502

    Joined:
    Jul 10, 2010
    Location:
    Dallas, TX
    #11
    As a frequent android/iPhone switcher.. make sure before pulling your sim outta the phone that you turn off iMessage. That will take your number off iMessage. Then just go into your other devices and where it says you can be reached at these address, make sure you uncheck your phone number and just leave the email you'd like to be reached at there.
     
  12. strausd thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #12
    My phone number isn't showing up as an address on my iPad in the first place, and that is why I am so confused.
     
  13. cheezeit macrumors 6502

    Joined:
    Jul 10, 2010
    Location:
    Dallas, TX
    #13
    Is your iPhone on iOS 6? My GF had that issue at first. Then once signed into icloud/imessage on the iphone it appeared on the iPad.
     
  14. strausd, Dec 30, 2012
    Last edited: Dec 30, 2012

    strausd thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #14
    I am still on 5.1.1.


    -----------------

    And I just went ahead with your suggestion and it seems to be working for the time being.
     
  15. jrswizzle macrumors 603

    jrswizzle

    Joined:
    Aug 23, 2012
    Location:
    McKinney, TX
    #15
    Interesting - my buddy with a GS3 gets my texts just fine. When I send it auto tries to send as an iMessage then sends as text message automatically if it doesn't work.
     
  16. strausd thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #16
    Just out of curiosity, did your friend ever have iMessage set up on an iPhone?
     
  17. RandomKamikaze, Dec 31, 2012
    Last edited: Dec 31, 2012

    RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #17
    I had an issue after moving from an iPhone 5 running the iOS beta to my Nexus 4. Even after switching off iMessage texts weren't coming thru.

    In the end I read something that said turn off iMessage on your device, get another iPhone (not yours, so a friends or something) turn off iMessage on their device, send a text message from their device to yours and then turn their iMessage back on. After this everything worked as normal for me.
     
  18. jrswizzle macrumors 603

    jrswizzle

    Joined:
    Aug 23, 2012
    Location:
    McKinney, TX
    #18
    That's a good question - he upgraded from a 3GS but don't know if he ever configured much
     
  19. strausd thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #19
    Seems like a huge pain for something as simple as sending a text.
     
  20. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #20
    It was. And I was annoyed that switching it if simply didn't work. Fortunately though I only had to do it on one device. Other iPhone users can text me no problem and I haven't told them to do anything out of the ordinary.
     

Share This Page