iMessage and email address

tctony

macrumors 6502a
Original poster
Jun 15, 2009
684
0
Is there any reliable way to make iMessage actually send from my phone number instead of my email? Apple has failed so hard in this regard.
 

r2shyyou

macrumors 68000
Oct 3, 2010
1,758
4
Paris, France
Is there any reliable way to make iMessage actually send from my phone number instead of my email? Apple has failed so hard in this regard.
Are you saying that the following isn't working?

Settings > Messages > Send & Receive> Start new conversations from > [select your number]
 

tctony

macrumors 6502a
Original poster
Jun 15, 2009
684
0
Are you saying that the following isn't working?

Settings > Messages > Send & Receive> Start new conversations from > [select your number]
Nope doesn't work on my iPhone or my iPad.

New convos always start from my apple ID.

----------

don't blame Apple buddy check your settings...my iMessgae comes from email and /or phone number
I don't want it to come from my email, that's the point. Apple failed hard in syncing iMessage and making sure it only comes from your number.
 

CB1234

macrumors 6502a
Sep 20, 2012
765
326
Dubai, UAE
Where are you based?

I have this problem in Middle East, where FaceTime is blocked by local authorities.

I wonder if you are based in ME as well.
 

stuaz

macrumors 6502
Jun 16, 2012
446
1
Mine works fine. All new conversations start from my phone number on my iPhone 5, (old 4), 3GS, iPad and RMBP.
 

r2shyyou

macrumors 68000
Oct 3, 2010
1,758
4
Paris, France
Nope doesn't work on my iPhone or my iPad.

New convos always start from my apple ID.
This may seem like I'm "passing the buck" but I suggest reading through this Apple support article:

http://support.apple.com/kb/HT3529

There's a bunch of info that might be helpful.

Otherwise, if I was having this problem, I'd start by confirming the phone number associated with my Apple ID at appleid.apple.com. Then I'd probably turn iMessage off and back on. Then go from there.
 

ProudLoz

macrumors regular
Aug 26, 2012
240
0
All your devices need to be on iOS 6, specially the iPhone. I don't know how it works, but I believe that when the iPhone receives an iMessage through the phone number, it just forwards the iMessage to the other devices that don't have the number attached to the device.
 

tctony

macrumors 6502a
Original poster
Jun 15, 2009
684
0
This may seem like I'm "passing the buck" but I suggest reading through this Apple support article:

http://support.apple.com/kb/HT3529

There's a bunch of info that might be helpful.

Otherwise, if I was having this problem, I'd start by confirming the phone number associated with my Apple ID at appleid.apple.com. Then I'd probably turn iMessage off and back on. Then go from there.
Semi-bump but thanks. Apple already had my phone number - but it wasn't listed under "Mobile Phone". I changed that, then logged out of iMessage on all my accounts (iPhone, iPad, computer) and my phone number was available under the iMessage settings after I logged back in.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.