iMessage and FaceTime activation problem

Discussion in 'iOS 7' started by weas, Jun 11, 2013.

  1. weas macrumors member

    weas

    Joined:
    Nov 4, 2012
    Location:
    Seville, Spain
    #1
    Hi everyone,
    I've been using iOS7 for a few hours and I can't use FaceTime or iMessage. When I go to settings/iMessage it says "waiting for activation". Same thing with FaceTime.
    Anyone else having that problem? Is there any solution?
     
  2. johnxttt macrumors member

    Joined:
    Jun 10, 2013
    #2
    So i posted in a different thread, but HERE YOU GO:

    OKAY! so after 12 hours of trying to get my iMessage to work.. i decided to restore.. Here's my steps:

    Restored my iPhone (with the beta)..
    Got the "Cannot activate message without a UDID".
    Put in DFU mode..
    Restored back to iOS 6.1.4 (I didn't have a jailbreak so didn't matter much)
    Then UPDATED (not restore) back to iOS7 beta 1.

    I think a key point is that when you restore back to 6.1.4, DO NOT RESTORE FROM A BACKUP. Set up as a new iPhone, and as soon as you can, update back to iOS 7.

    My iMessage and Facetime are both activated now
     
  3. imlboy macrumors newbie

    Joined:
    May 27, 2013
    #3
    I too experienced the activation problem with iMessages and Facetime. But what I did was I restored it to 6.1.4 clean, then let iMessages and Facetime activated in 6.1.4. Then upgraded to 7 beta 1. Now everything works flawlessly.
     
  4. weas thread starter macrumors member

    weas

    Joined:
    Nov 4, 2012
    Location:
    Seville, Spain
    #4
    I did the same thing as you did. Installed iOS7 clean and now FaceTime and iMessage work fine.
    Thanks!
     
  5. Bawstun macrumors 65816

    Bawstun

    Joined:
    Jun 25, 2009
    #5
    I have tried this. More than once.

    Does anyone have any other suggestions? This is so very irritating - and I've run into this problem on different iOS versions before too, so it's not just an iOS 7 thing. iMessage is horribly buggy trying to get it to activate.
     
  6. ts599 macrumors newbie

    Joined:
    Jan 29, 2011
    Location:
    U.S.A
    #6
    How did you get all your stuff back?
     
  7. iphone5person macrumors newbie

    Joined:
    Jul 5, 2013
    #7
    Help!

    yes i second this! i restored from backup to revert to iOS 6.1.4 on iPhone 5 Verizon before I read this thread, but if you set up as a new iPhone, can you get all your previous stuff back or no? This is urgent! :(
     
  8. gomoq13 macrumors 6502

    gomoq13

    Joined:
    Jun 17, 2013
    Location:
    Singapore
    #8
    I had this issue on all the iPhones and iPad I had iOS 7 installed on. All I did was restart the iDevices and Facetime and iMessage got activated and worked as normal.
     
  9. aimee.elizabeth macrumors 6502

    Joined:
    Sep 28, 2012
    #9
    This problem doesn't exist exclusively on ios 7, it has been around for years. It happened to me as well, and I tried many methods, and what ended up working for me after hours of work was just to reinstall ios 7 and then using an old backup and waited for a few hours, and it just magically worked. If you google this problem you can find many solutions and I suggest you try all of those or as many as you can, and one of them is just to wait for 24-48 hours and see if it'll activate in time.
     

Share This Page