iMessage and Facetime bug on an iPhone 3Gs

kimononono

macrumors newbie
Original poster
Sep 27, 2006
20
0
Hi everyone,

I've been spending the last 3 days looking for a solution about this bug!

Here's the situation :

My boyfriend has an iPhone 3Gs

I just got a new iPhone 4s

We live in Switzerland and both changed carrier, so we got a new sim card that each came with a temporary number. We did use our temporary numbers for couple of weeks so iMessage and facetime were activated with these numbers and were working flawlessly. But then our new phone numbers kicked in and everything became a mess.

With my iPhone 4s the problem was solved quickly by simply setting iMessage to OFF and Resetting Network settings. Then set iMessage back to ON and all my information were updated and iMesage was activated with my new phone number and AppleId


But my boyfriend's iphone (3Gs) is more problemaic. After I reset network settings, iMessage decided not to activate with his new phone number. I mean, his phone number is working and appears correctly in the "phone" settings, but iMessage wont accept it! I tried all the methods I found on the net until I got to the most radical of all... I completely erased content and settings and set the iphone as a new phone. I even asked him to create a new AppleId so the phone is currently empty and just as it would be if we sold it.
I thought : "now there's no way imessage wont work", but guess what? It does not work! Even worse.. Facetime has completly disapeared from the settings (both from the phone settings and the general settings). Activating iMessage only works if I put his AppleID but then I cant enter it his phone number. And another weird things... now all incoming calls are "masked" he cant see incoming phone numbers

I dont get it! How can I FORCE imessage to consider his current phone number for activation?

We're talking about a 2 year old iPhone 3Gs so I cant get any Apple support.


Please help! My head is going to explode!
:(

Edit : Forget everything i said about FaceTime! It was never meant to work with a 3GS! I simply got mixed up!
 
Last edited:

kimononono

macrumors newbie
Original poster
Sep 27, 2006
20
0
You can still get support from Apple if you call them or take it to a Genius bar.
In switzerland there are only 3 genius bars : the closest to where i live is 2 and à half hours from here :(

I Will try to call Apple though, but not sur they'll want to help since i never paid for an extended Apple garantee
 
Comment

DankNugz

macrumors regular
Jan 11, 2012
143
0
Bay Area, CA
In switzerland there are only 3 genius bars : the closest to where i live is 2 and à half hours from here :(

I Will try to call Apple though, but not sur they'll want to help since i never paid for an extended Apple garantee
Ouch :( That sucks about the Apple store part.

Apple does tend to back their products even though it may be an old model, so I would definitely give them a call if I were you.

One thing I just thought of is to do a hard reset by holding the power and home buttons until it shuts off and the Apple logo appears. This may fix the problem.
 
Comment

kimononono

macrumors newbie
Original poster
Sep 27, 2006
20
0
try to activate imessage with wifi instead of 3g.
Does not work
One thing I just thought of is to do a hard reset by holding the power and home buttons until it shuts off and the Apple logo appears. This may fix the problem.
Does not work.
Apple does tend to back their products even though it may be an old model, so I would definitely give them a call if I were you.
You were right! I spoke with them and they were really nice. They told me about their 5 five different procedures to re-activate iMessage, but none of them worked : I had already tried all of them!Then the guy spoke to his supervisor and at this point, even the supervisor had to admit that the whole problem was probably iMessage and not my iphone or the way I did anything. They asked me to either go to Geneva (the "closest" GeniusBar) or wait for the next ios5 update which might include an update of iMessage (they've had a lot of calls about this problem).

The GeniusBar option might not solve the case though... I'll try to call them, cuz even though they prefer to meet people directly, there's no way I'm gonna drive 2 and à half hours , just to hear that there's nothing they can do
 
Comment

TLewis

macrumors 65816
Sep 19, 2007
1,130
0
left coast, US
Comment

kimononono

macrumors newbie
Original poster
Sep 27, 2006
20
0
These are long shots, but two things to try, if you haven't already tried them:

  1. First, disable iMessage on the device, and follow the instructions here, and then try to reactivate iMessage (this solves a different problem, but it might solve yours, too): http://lifehacker.com/5873353/fix-t...messages-if-you-switch-to-android-from-iphone
  2. Reset your phone settings (again, this is for a slightly different problem, but it might solve it, too): https://support.apple.com/kb/HT4246
of course i'v tried all that! These are the 2 soft methods! The phone is currently empty with everything that could be reset, reset. iMessage has its database somewhere and just won't link my phone with its new phone number. And apple can't do it manually :(
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.