iMessage and Facetime not activating

Discussion in 'iOS 7' started by Crwmlw, Sep 18, 2013.

  1. Crwmlw macrumors regular

    Crwmlw

    Joined:
    Jun 18, 2011
    Location:
    Chicago,Il
    #1
    Hello everyone. I downloaded ios 7 and now facetime and iMessage wont activate. They both say Waiting for activation, I tried resetting network settings and that didnt work. Any ideas please?
     
  2. jwc6160 macrumors member

    Joined:
    Aug 17, 2011
    #2
    Same issue. It spins for a while then tells me to check my network. Everything else seems to be working.

    Any ideas? Don't have a text plan and no iMessage is a problem for me.

    Thanks
     
  3. wishman35 macrumors regular

    Joined:
    Jan 9, 2009
  4. rsxmachine macrumors 6502a

    Joined:
    Dec 19, 2007
    #4
    I installed IOS7 GM last week on 3 phones. Had this issue on one of them and there is no fix. I did everything possible, restore, recover from backup. not logging in to icloud. It didn't matter, its like the problem was associated with the phones serial number. My fix was downgrading back to ios 6.1.4. Also note that it may connect after a while of trying and then just randomly disconnect again. Makes no sense to me.
     
  5. jwc6160 macrumors member

    Joined:
    Aug 17, 2011
  6. rsxmachine macrumors 6502a

    Joined:
    Dec 19, 2007
    #6
    i agree, i will try ios7 again today on the same phone.
     
  7. Ashin macrumors 6502a

    Ashin

    Joined:
    Jun 19, 2010
    #7
    I think Apple's servers are just being hammered.

    Either keep trying, or be patient and try later
     
  8. rsxmachine macrumors 6502a

    Joined:
    Dec 19, 2007
    #8
    true but apples servers were not hammered last week. the only thing i didn't do is wait 24 hours. all of this was done in a matter of hours.
     
  9. Jimbo Asprilla macrumors regular

    Jimbo Asprilla

    Joined:
    Sep 21, 2009
    #9
    Me too, wasn't sure if it was just a temporary problem with all the users updating at the same time, seemingly not.....
     
  10. joesegh macrumors regular

    Joined:
    Jun 17, 2009
    Location:
    New Jersey, USA
    #10
    Same issue here. Hoping it is a server-side issue and will get fixed promptly.

    I've also been getting this message in push-enabled apps that I should connect to iTunes to use push notification.

    Not sure what that one is all about.
     
  11. sbessel macrumors newbie

    Joined:
    Jul 5, 2010
    #11
    I am seeing the same thing... hope it is just a server issue and will be fixed soon. It renders Find Friends useless, the alerts will not go away.
     
  12. jwc6160 macrumors member

    Joined:
    Aug 17, 2011
    #12
    Getting more frustrating as time passes. Is it weird that this is the only thing that isn't working for me? I mean, I updated fine, had a few settings issues but nothing major. It just won't connect to activate these 2 things. Weird.
     
  13. sodaftl macrumors member

    sodaftl

    Joined:
    Jan 27, 2008
    Location:
    Fort Lauderdale, FL
    #13
    Try and check that you Apple ID password is correctly entered (maybe in iTunes store, for example), since both apps depends on your Apple ID.
     
  14. HipHopTrex macrumors member

    Joined:
    Mar 9, 2012
    #14
    I'm also having the same issue.

    Hoping it's just a server issue because the update is new so they're getting hammered like someone else said. That and a couple apps I need for school not being updated are the reason I'm not downloading iOS 7 on my iPad just yet.
     
  15. Impuls3101 macrumors member

    Joined:
    Sep 13, 2013
    #15
    I had a similar problem on one phone with my cell service not activating. I had to reset network settings and reboot the phone to get everything working. It might be work giving a try if it doesn't resolve it self. Settings -> General -> Reset -> Reset Network Settings
     
  16. joesegh macrumors regular

    Joined:
    Jun 17, 2009
    Location:
    New Jersey, USA
    #16
    Did that twice already, no discernible change. Perhaps third time is the charm?
     
  17. tfa8rva macrumors member

    Joined:
    Jan 18, 2011
    #17
    Think I may wait a while before pulling the trigger on upgrading.
     
  18. jwc6160 macrumors member

    Joined:
    Aug 17, 2011
    #18
    4 hours in and still not working. All is working and I am pleased aside from not being able to message.
     
  19. HipHopTrex macrumors member

    Joined:
    Mar 9, 2012
  20. jwc6160 macrumors member

    Joined:
    Aug 17, 2011
    #20
    Really starting to get irritated with this. If it isn't ready don't release it.
     
  21. joesegh macrumors regular

    Joined:
    Jun 17, 2009
    Location:
    New Jersey, USA
    #21
    Trying restoring to factory and then loading my iTunes backup. Jesus this is annoying.
     
  22. rsxmachine macrumors 6502a

    Joined:
    Dec 19, 2007
    #22
    Nothing works. I installed again and while it worked at the beginning like last time. It just disconnected and won't activate again. This is an apple issue. Restores don't work
     
  23. Purex macrumors member

    Joined:
    Aug 22, 2013
    #23
    i Got the same problem " Waiting for Activation ", and i was able to solve it, doing the following procedure:

    "If you have an iPhone and for some strange reason (you switched phone numbers or phones) your iMessages app is only showing your e-mail address and not your phone number, or the wrong phone number, turn off iMessage / Facetime, simply text Act1vate to +447537410277 . After that, turn iMessage on, and reboot. It Should be working after that "

    I adapted the text a bit, cause i followed the instructions also from this video: http://www.youtube.com/watch?v=VVmbdvbZMbQ


    WARNING: You will be charged an International SMS, but hey, there´s no free lunches, right ? :p

    ( Taken from here - http://forums.macrumors.com/showthread.php?t=324487&page=10 )
     
  24. joesegh macrumors regular

    Joined:
    Jun 17, 2009
    Location:
    New Jersey, USA
    #24
    Well I seem to have fixed my issues. Within iTunes I created a backup, then did a "Restore iPhone" (NOT "Restore Backup").

    Then after the phone was wiped I restored the backup, and now iMessage, FaceTime, and push notifications are all working as expected.
     
  25. rsxmachine macrumors 6502a

    Joined:
    Dec 19, 2007
    #25
    Might have another solution. If you have multiple devices using same iMessage, log out and disable from all devices and reset all devices. Then try again to log into icloud on all of them.
     

Share This Page