iMessage and FaceTime show wrong number after SIM change

Discussion in 'iOS 8' started by zanvetto, Jan 28, 2015.

  1. zanvetto macrumors newbie

    Joined:
    Dec 14, 2008
    #1
    Hi.
    Im writing because I need some help with my iPhone.
    I have a Factory Unlocked iPhone 5 with iOS 8.1.3 that I regulary use with my local carrier. Last week I was on vacation outside my country and I used a local SIM with a local number (it worked fine). Yesterday I returned home and switched back to my regular SIM card and it seems there is a mess with the Phone number, iMessage and FaceTime.
    Let me explain: When I inserted the SIM the phone recognized the phone number without the Country Code (Insted of showing: +Country Code & Phone number its showing + Phone Number). I setup the correct phone number at Settings -> Phone -> My Number (+Country Code & Phone Number). The phone works fine but iMessage and FaceTime are not working because the number is not correct.
    I tried to change the number but its greyout (no option to select it). I also reseted the network settings and tried to take out and put in again the SIM but nothing seems to work.
    I dont know how to fix this issue. I will appreciate any help.
    Please let me know if you need any additional info.
    Thank you.
     
  2. MacCubed macrumors 68000

    MacCubed

    Joined:
    Apr 26, 2014
    Location:
    Florida
    #2
    If you disable iMessage and FaceTime in the settings, it will in a way, reset the settings of the apps and allow you to select your correct phone number.
     
  3. AppleP59 macrumors 6502

    Joined:
    Feb 24, 2014
  4. zanvetto thread starter macrumors newbie

    Joined:
    Dec 14, 2008
    #4
    I cannot select te correct number because its the only number that is display... and its grey out... I cannot add the additional number at the beginning.

    Regarding the email address... I can add my email address but that does not fix the number issue. I will be able to use iMessage and FaceTime with the email but not with the phone number (I dont give to every contact my email address).

    Any additional ideas?

    Thank you.
     
  5. MacCubed macrumors 68000

    MacCubed

    Joined:
    Apr 26, 2014
    Location:
    Florida
    #5
    Did you have a back-up of the phone before you left on vacation?
     
  6. zanvetto thread starter macrumors newbie

    Joined:
    Dec 14, 2008
    #6
    Yes!... But its a weird behavior.

    I spoke with an apple supprt representative and they had no idea on how to solve the issue.
     
  7. MacCubed macrumors 68000

    MacCubed

    Joined:
    Apr 26, 2014
    Location:
    Florida
    #7
    Try restoring from the backup and see what happens.
     
  8. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #8
    iMessage has been REALLY flakey lately.

    I just got back this morning from an international trip. On the trip one of my numbers (I have 2 iPhone 6) disappeared from my iMessage... similar issue to yours, it showed back up but greyed out.

    I tried everything, but it relies on a short message to activate, so activating it overseas is next to impossible.

    Apple needs to get it together with how they implement the activation of the message process. Seems like it wouldn't be rocket science to activate through the internet instead of via SMS. In this day in age, they can validate the number belongs to you by the fact the sim is in the phone, or if they want to get real fancy, use the AT&T interface they use to verify upgrade eligibility... not rocket science here.

    As soon as I got back to the US, I turned iMessage off then back on and all was fine.
     
  9. gordon1234 macrumors 6502a

    Joined:
    Jun 23, 2010
    #9
    Just to confirm, have you tried turning off iMessage completely, restarting, then turning it on again?
     
  10. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #10
    Difficult to advise further as you are for some reason being coy about the countries and carriers involved by this has the hallmark of a carrier-interconnect issue as the cause but now the foreign SIM has loaded its carrier settings in an odd way a restore from backup may be the only way out.

    Some countries with flakey cellular coverage have long registration timeouts necessary for local network access but it can hold you to the foreign network when you return home. If it hasn't sorted itself 24hrs after returning home then I think you'd need to restore from backup, or do that if you can't wait that long.
     
  11. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #11
    Try turning off iMessage & FaceTime then resetting Network Settings, then turning iMessage and FaceTime back on before nuking everything with an old backup.
     
  12. zanvetto thread starter macrumors newbie

    Joined:
    Dec 14, 2008
    #12
    The issue continues...
    Today I restored my company iPhone 4S iOS 8.1.3 and it started the same issue... the iMessage is showing a wrong country code number.
    I tried to restore from a old backup and it shows the correct number but its not able to use it. After a while it changes the phone number (modifing the country code) and activates with the wrong number.
    At this point I dont have any idea of what is happening.
    Any help will be great.
    Thank you.
     
  13. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #13
    So with the SIM card in dis you try turning off iMessage? And then turning it back on?
     

Share This Page