iPhone iMessage and Facetime wont verify apple ID or Number.

Discussion in 'Jailbreaks and iOS Hacks' started by Sp1n, Aug 12, 2012.

  1. Sp1n macrumors newbie

    Joined:
    Aug 11, 2012
    #1
    Device: iphone 4 GSM
    ios: 5.1.1 (9B206) custom firmware
    Jailbreak: Redsn0w 0.9.14b2
    Unlock: Ultrsn0w

    Hi I just updated my iphone 4 to ios 5.1.1 using custom firmware and unlocking with ultrasn0w. first I tried updating to 5.1.1 (9B208) but kept getting errors 14 & 1602, so I tried ios 5.1.1 (9B206) and was able to restore jailbreak and unlock.

    Since upgrading I have not been able to send imessages or make facetime calls, when I try activating it just hangs and doesnt activate.
    I have tried reseting my network as mentioned in another thread but it didnt help, I have also restored about 3x's and that hasnt helped either.

    Does someone know why I cant activate imessage & facetime, I really need help please.

    I dont know if this helps but sometimes I have to turn airport mode on and off for my iphone to recognise my phone number in phone setting. and I am able to download from the appstore, so my apple id is OK.

    Thanks in advance.
     
  2. Sp1n thread starter macrumors newbie

    Joined:
    Aug 11, 2012
    #2
    doesnt anyone know why facetime and imessage wont work on custom ios 5.1.1
     
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    It has nothing to do with your firmware.
    It is because you are using the phone on an unofficial carrier.

    iMessage and FaceTime send activation messages to become activated. The networks of official carriers of iPhone process those codes correctly, unofficial carriers see them as an International SMS.

    Therefore they do not get processed correctly and therefore your cell number on an unofficial carrier does not get activated for iMessage and FaceTime.
    Very common issue on unofficial carriers

    I do not know of a guaranteed fix
     
  4. Sp1n thread starter macrumors newbie

    Joined:
    Aug 11, 2012
    #4
    Thanks dhlizard your answer is the only one that makes sense...
    how can i find out who the original carrier is, I bought this iphone 2nd hand about 2yrs ago and I dont know where the guy that sold it to me is.. I havent seen the guy in almost a year.

    Thanks

     
  5. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    Actually Facetime/Imessage works fine with Ultrasn0w on 5.1.1.

    Is sometimes goes wrong in the activation.
    first thing try ejecting and reinserting SIM, after jailbreaking the carrier settings are set to the original carrier, ejecting and reinserting resets it to your current network, you can check that in Settings/General/Info look at the carrier.
    You can also check in Settings/Facetime and see if any error is seen at your phonenumber or Settings/Telephone see if your number is correctly displayed.

    If that doesn't work install SAM from the repo.bingner.com in Cydia.
    With SAM backup activation than deactivate the phone, clear push and stockify, than reactivate either via iTunes or over WIFI, that should do the trick.

    Also turn off facetime and on again.
     
  6. Sp1n, Aug 18, 2012
    Last edited: Aug 18, 2012

    Sp1n thread starter macrumors newbie

    Joined:
    Aug 11, 2012
    #7
    Hi dhlizard & TriJetHero

    I have been trying the steps posted on the link you gave me for a few days now, my problem is after I get to step 6, my sim card becomes unregognized by itunes and wont allow me to sync. so because I cant sync, I am not getting the wildcard option, meaning I cant continue on to step 7.

    Also for some reason I can only upgrade to ios 5.1.1 (9B206) when ever I try upgrading to ios (9B208) I keep getting errors 14, 1600, 1602.

    even though I have my AV & firewall switched off, and confirmed that my USB ports work fine, I still get the above errors.

    But when I try upgrade to 5.1.1 (9B208) it always works on first try..

    is there any difference between the two, could that be a reason why I keep failing when attempting the steps with SAM.

    Thanks

    edit** before installing sam, I checked my phone settings, and my phone number is displayed properly, inc the country code. But when I open facetime it only shows my apple ID and not my phone number. another thing in setting>>general>>about it shows my carrier network and carrier as vodafone. which is the carrier my sim card is with.
     
  7. TriJetHero, Aug 19, 2012
    Last edited: Aug 19, 2012

    TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #8
    If you get the message that your simcard isn't recognized than ultrasn0w isn't working.
    Make sure you have it installed or reinstall

    Did you preserve your baseband when you upgraded to 5.1.1? What is your current baseband? Settings/General/Info/ on the bottom, modemversion

    try activating it over wifi.

    If all else fails, deactivate with SAM and try to rejailbreak with latest redsn0w and during the process select activate, also select option NOT to install cydia as you already have it on your phone.

    For the error's on the restore, try using the pwned-DFU for the 9B208
     
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #9
    Thread starter,
    As I said originally, this is a common issue with using these phones on unofficial networks,

    I do not know of a guaranteed fix.
     
  9. Sp1n thread starter macrumors newbie

    Joined:
    Aug 11, 2012
    #10
    hi trijethero ultrasn0w works fine and can sync to itunes, its only after I follow step5

    **Step 5. Click on the Revert Lockdown to stock. You will get a message saying it's successful. And then click on De-Activate iPhone (clear push). You will get a success message appears for second times. Simply click on OK then to close it.***

    after step5, step 6 says to connect and sync with itunes. thats when my sim becomes unrecognised.


    I preserved my basebane and am on 01.59.00

    I havent tried connecting over wifi, will try that now.

    the only way I can see to activate with redsn0w, is if I have one of the lockdown backup tickets, which I dont have because I didnt unlock this iphone with sam. if there is another option to activate, I dont know were that is.

    I have tried, but for some reason I cant install
    NO_BB_iPhone3,1_5.1.1_9B208_Restore
    I made sure my av and firwall is off, and confirm that my usb ports are working fine but still it wont allow me to install (9B208)

    I can install NO_BB_iPhone3,1_5.1.1_9B206_Restore and it installs with no problems..

    the only way I can install iPhone3,1_5.1.1_9B208_Restore is if create cfw with sn0wbreeze

    Hi dhlizard, all I can do is try. apparently others have had this problem and have been able to fix it, so hopefully I will be able to fix it too..
     

Share This Page