iMessage and gevey

Discussion in 'Jailbreaks and iOS Hacks' started by daooof, Jun 23, 2012.

  1. daooof macrumors regular

    Joined:
    Nov 24, 2010
    #1
    Im in London using a vodafone sim with my AT&T 4S using the gevey. Right now iMessage is being sent through my email, and maybe(I'm not sure) my US phone number.

    Right now my english number won't use iMessage. How do I fix this? Also can I keep my US number on it as this is only for a month.

    Thanks
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    If you are using a non-native carrier service, the issue is iMessage and FaceTime cannot get the cell number registered. Only native carriers have the functionality built in for the activation code to register iMessage and FaceTime for a cellular phone number.
     
  3. daooof thread starter macrumors regular

    Joined:
    Nov 24, 2010
    #3
    Vodafone is one of the biggest cellular companies in the world, of course it's a native iPhone carrier.
     
  4. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #4
    Yea you're probably right saying Vodafone has native iPhone support but you're using an AT&T iPhone with a Vodafone sim. Which is what lizard is trying to explain. That number associated with the Vodafone sim can't register the activation code with iMessage and FaceTime.

    I would also like to apologize in advance as I am not an unlocker. But based on what I've read in this thread, that's my understanding.
     
  5. daooof thread starter macrumors regular

    Joined:
    Nov 24, 2010
    #5
    Yes, I know that's the problem... I'm trying to ask for how to solve it. My phone is jailbroken so I can edit system settings.
     
  6. Mrlal8 macrumors member

    Joined:
    Jan 16, 2012
    #6
    you cant end of story
    happened to me and my digicel, tried everything even used iFIle changed the internal numbers according to whatever i read online in a previous thread. signed out of my email then turned iMessage on and off nothing happened. Then got my 4s factory unlocked through att and now my foreign sim number registers on iMessage
     
  7. tok macrumors member

    tok

    Joined:
    Mar 8, 2012
    #7
    How did you change your internal number? I couldn't find any way to do that on the 4s
     

Share This Page