iMessage and Green Bubble Text

Discussion in 'iOS 5 and earlier' started by Maskusee, Oct 17, 2011.

  1. Maskusee macrumors 6502a

    Maskusee

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #1
    I have familly in other countries and been using iMessage with them instead of WhatsApp. Once in a while i see that my outgoing texts are in a "Green Bubble"

    I understand that this means that the message will be sent out as a regular text and i will have to now pay charges thru my cell provider (Grrrrr).

    My question is, does this happen because of the senders poor data connection or the receipeints?

    Does anyone here know?
     
  2. mreddys10 macrumors regular

    Joined:
    Jul 29, 2008
    #2
    It could be either of the two. Doesn't the send button turn green before sending the message as a regular SMS?
     
  3. Saberon macrumors 6502a

    Joined:
    Sep 16, 2008
  4. r2shyyou macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #4
    In my experience, it happens because of the recipients poor data connection.

    Not if the sender has a decent data connection. I've sent iMessages and waited to see that they'd been "Delivered" only to receive a little message saying that they were "Sent as Text Message".

    There's a toggle in Settings>Messages where you can enable sending as SMS when iMessage can't deliver the message. I have sending as SMS enabled because I have a texting plan and don't mind the occasional USD $0.25 for an international text message but if you don't want to pay that, you should disable sending as SMS.
     
  5. Maskusee thread starter macrumors 6502a

    Maskusee

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #5
    That's exactly what's happening with me. It goes out blue and then changes to green.

    If I turn the iMessage only in settings then I won't be able to use it with local friends.

    I also believe its the recipients low or bad connection that's causing it.
    AT&T must be loving me right now.
     
  6. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #6
    No, there's another switch. The top one that says 'iMessage' is at the top. Leave that on. That's not what he was talking about.

    Lower down there's one that says 'Send As SMS.' Turn that one off.

    That means you can text people without iPhones, but when you send an iMessage and it can't get through it'll just tell you that rather than sending it as text message.

    That's exactly what you want.
     
  7. Maskusee thread starter macrumors 6502a

    Maskusee

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #7
    Wow, you guys are great.

    Thank you!!!!
     
  8. Scott90 macrumors 6502

    Joined:
    Jul 14, 2008
    #8
    Better yet, it will ask you if you want to send it as SMS if you have that off. This will let you decide per case whether you want to send as SMS or not.
     
  9. Calidude macrumors 68000

    Calidude

    Joined:
    Jun 22, 2010
    #9
    I don't get it. All you have to do is send iMessages to people via their email address and the text message thing isn't a problem.
     
  10. Maskusee thread starter macrumors 6502a

    Maskusee

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #10
    But then why not just email the person?

    I use text to get a quick message off that the recipient can read right away.
    As far as emails go, it all depends on push/fetch.
     
  11. Runt888, Oct 17, 2011
    Last edited: Oct 17, 2011

    Runt888 macrumors 6502a

    Joined:
    Nov 17, 2008
    #11
    You (or your recipients, in this case) can set your email address to be used to receive iMessages. Then you send an iMessage to them just like you normally would, except select their email address instead of their phone number. They will receive it exactly the same as if you sent an iMessage to their phone number.
     
  12. Maskusee thread starter macrumors 6502a

    Maskusee

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #12
    Thank you, i wasn't aware of this.
     

Share This Page