iMessage and Jailbreak 5.0.1 issue

Discussion in 'Jailbreaks and iOS Hacks' started by naujoks, Feb 1, 2012.

  1. naujoks macrumors 6502

    naujoks

    Joined:
    Jul 6, 2008
    Location:
    London, UK
    #1
    I only noticed that there is a problem when someone called me after I didn't reply to 3 messages he sent me. Turns out I never got them, and he never received the SMSs I sent him. Normally text messages get sent ok, but iMessages disappear.
    I tried to switch iMessage off, but the phone freezes complete when doing so, forcing me to hard reset (but at least iMessage was then switched off when rebooting). Normal text messages working fine.

    Anyone who's got a solution to this problem?
     
  2. docgerrard macrumors 6502

    Joined:
    Jul 21, 2011
    #2
    Hmm my phone sends them all right and i think receives them too... but i just went to try to turn it off to see what was happening.

    it turned off fine but turning it on makes it freeze without question. anyone else have these iMessage problems?
     
  3. EngageWithRage macrumors 6502

    EngageWithRage

    Joined:
    Jan 30, 2012
    Location:
    Your girlfriend's house
    #3
    I had an issues with them not working after the jailbreak. I just turned off iMessage, Signed out of my account and rebooted the phone. I signed back in and turned on iMEssage and waited a bit for it to connect. After that worked fine.
     
  4. RotaryP7 macrumors 6502a

    Joined:
    Aug 31, 2011
    Location:
    Miami, FL
    #4
    How do you guys even know if it's working. I've texted people already back & forth on iMessage. No issues. I wonder if they texted back and I didn't get it? :rolleyes:

    Some girl didn't reply to my iMessage text yesterday lol, then again she could be ignoring me..
     
  5. naujoks thread starter macrumors 6502

    naujoks

    Joined:
    Jul 6, 2008
    Location:
    London, UK
    #5
    It's the phone completely freezing in the settings menu which is a sure sign that something's amiss.
     
  6. MajesticNJ macrumors regular

    MajesticNJ

    Joined:
    Jun 20, 2009
    Location:
    Central NJ
    #6
    This happened to me yesterday and here is what I did to fix it.
    I turned imessage off and yes my phone locked up. Press and hold sleep and home till phone hard resets.

    Then I went back into settings and turned off Facetime.
    Press and hold sleep till you get red swipe to shut down.

    Shut down all the way then power back up again.

    Go into settings and enable facetime and confirm the settings.
    You will be asked for your account and password with Apple. Log in. Facetime gets activated. Then check imessage and it should be good too.

    That fixed it all for me but not after going crazy for two hours trying to find out why it wasn't working.

    Good luck.

    Fred
     
  7. naujoks thread starter macrumors 6502

    naujoks

    Joined:
    Jul 6, 2008
    Location:
    London, UK
    #7
    Unless this bug gets fixed I think I'll just leave these things switched off.
    Even if I get it to work again, there's not telling when it will break again and how many messages will get lost in the course of it.
     
  8. EngageWithRage macrumors 6502

    EngageWithRage

    Joined:
    Jan 30, 2012
    Location:
    Your girlfriend's house
    #8
    All my messages were sent, you have to make sure your to and from settings are setup with your number etc..
     
  9. gothamguy macrumors member

    Joined:
    Oct 20, 2011
    #9
    I have had no problem using iMessage, but I just turned it off and back on to see if I had the same issue, and I don't. Maybe there is a conflict with another app installed?
     
  10. zaxdude macrumors 6502

    Joined:
    Mar 11, 2011
    #10
    I'm having zero issues as well. I wouldn't go as far as calling this a "bug" that results from the jailbreak. In fact, from my experience so far the jailbreak has been perfectly stable.

    I'm not suggesting you are not experiencing an issue, but I think your issue is originating from a different source.
     
  11. UCLAKoolman macrumors 6502a

    Joined:
    Jun 21, 2010
    #11
    I had a strange issue where my text app wasn't recognizing my iPhone toting friends, so my texts were green. I disabled and enabled iMessage and everything has been fine since.
     
  12. The Mad Hatter macrumors 6502a

    The Mad Hatter

    Joined:
    Oct 12, 2004
    Location:
    SoCal
    #12
    I had iMessage problems on both my 3GS & iPad when I JB/upgraded to 5.0.1. Couldn't send/receive iMessages at all. What finally worked for me was re-jail breaking and setting it it up as a new iPhone/iPad (as apposed to restoring my old backup settings which I did the first time around.) It's a PITA to setup you iPhone from scratch (PKGBackup helped a lot), but so far (knock on wood), I haven't had any problems since.

    HTH
     

Share This Page