iMessage and Personal Hotspot not working

Discussion in 'iOS 5 and earlier' started by Knifey-Spoony, Nov 4, 2011.

  1. Knifey-Spoony macrumors member

    Joined:
    Jan 29, 2010
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    I'm having a weird issue with my iMessage only working over wifi. When I'm on 3G I'm not a able to send or receive iMessages. My personal hotspot settings is no where on my phone. I've tried looking under network settings and even resetting the network settings... still nothing. If I perform a fresh restore and setup as a new device it's all fine. However when I try to restore from a backup via iTunes or iCloud I get the same issues. This method is all fine and dandy but I want to be able to retain my text/mms messages on my device. I already have them backed up onto my Mac with phoneview, but I want them on my device. I've even tried restoring to a back from my iPhone 4 from when I got it running 4.0.1 still nothing. By the way this issue is both on my 4 and 4s. Any help would be greatly appreciated.
    Thanks
     
  2. Knifey-Spoony thread starter macrumors member

    Joined:
    Jan 29, 2010
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Bump please
     
  3. brand, Nov 4, 2011
    Last edited: Nov 4, 2011

    brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #3
    There is no need to bump.

    Perform a clean install and wait for an iOS update in the future that might fix it or since they are already backed up on your Mac just deal with not having them on your phone.
     

Share This Page