iMessage annoyance

Discussion in 'iPhone' started by tomwalsh77, Nov 18, 2014.

  1. tomwalsh77 macrumors regular

    tomwalsh77

    Joined:
    Feb 12, 2012
    Location:
    Blackpool, UK
    #1
    I'm at the point where I've totally confused myself trying to figure this out so forgive me if there is an easy and obvious fix to this. I have an iPhone 6 and an iMac both setup on the same Apple ID. I get iMessages/SMS on both devices and also I can take calls on either. The problem is that when I text my girlfriend on her 3GS she sometimes receives the text from my email address associated with my Apple ID and sometimes from my phone number. This creates two separate entries in the messages app which are both from me. Have I set this up wrong somewhere and more importantly is it possible to fix this annoyance? :confused:
     
  2. Mr Kram macrumors 68000

    Mr Kram

    Joined:
    Oct 1, 2008
    #2
    there is checkbox where you select which address messages should originate. you must have one selected for you phone number one one device and one selected as your email address on the other.
     
  3. tomwalsh77 thread starter macrumors regular

    tomwalsh77

    Joined:
    Feb 12, 2012
    Location:
    Blackpool, UK
    #3
    That's what I thought but I've checked on both devices and they're both set to my phone number? There is no issue on my sons iPhone though. Could it possibly be a setting on my girlfriends phone?
     
  4. Mr Kram macrumors 68000

    Mr Kram

    Joined:
    Oct 1, 2008
    #4
    odd. don't think so unless for some reason when iMessage trumps SMS, it changes to the apple ID.
     
  5. tomwalsh77 thread starter macrumors regular

    tomwalsh77

    Joined:
    Feb 12, 2012
    Location:
    Blackpool, UK
    #5
    It's definitely odd and very annoying lol.
     
  6. eclipse01 macrumors 68020

    eclipse01

    Joined:
    May 16, 2011
    Location:
    Eau Claire, WI
    #6
    this has been happening around me A LOT lately, from everyone around me.
     
  7. tomwalsh77 thread starter macrumors regular

    tomwalsh77

    Joined:
    Feb 12, 2012
    Location:
    Blackpool, UK
    #7
    Not good :mad:
     
  8. eclipse01 macrumors 68020

    eclipse01

    Joined:
    May 16, 2011
    Location:
    Eau Claire, WI
    #8
    just delete your Apple id out of there and you should be good to go
     
  9. tomwalsh77 thread starter macrumors regular

    tomwalsh77

    Joined:
    Feb 12, 2012
    Location:
    Blackpool, UK
    #9
    Out of where?
     
  10. Mr Kram macrumors 68000

    Mr Kram

    Joined:
    Oct 1, 2008
    #10
    from the list of addresses where you can receive iMessage. unless you get messages from an iPod or something where you need it.
     
  11. eclipse01 macrumors 68020

    eclipse01

    Joined:
    May 16, 2011
    Location:
    Eau Claire, WI
    #11
    or uncheck it on the top and the bottom half I believe will go away

    I feel for some reason one of the updates checked both of them and screwed up the imessage system a bit
     
  12. tomwalsh77 thread starter macrumors regular

    tomwalsh77

    Joined:
    Feb 12, 2012
    Location:
    Blackpool, UK
    #12
    I'm sure I read somewhere that in order to get SMS relay working that I need to have an apple ID phone number and email address. Am I wrong?
     
  13. Mr Kram macrumors 68000

    Mr Kram

    Joined:
    Oct 1, 2008
    #13
    you need it only to set it up for some reason, then you can delete or inactivate the email.
     
  14. syfuman macrumors newbie

    syfuman

    Joined:
    Apr 17, 2010
    #14
    another thing to check is to see if your girlfriend has you listed twice in her contacts. she might have your appleID saved on 1 listing and your phone number saved on the other listing.
     
  15. tomwalsh77 thread starter macrumors regular

    tomwalsh77

    Joined:
    Feb 12, 2012
    Location:
    Blackpool, UK
    #15
    No just one entry in the contacts :-/
     
  16. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #16
    And you have "View All Contacts" selected? No just one of your contacts groups?
     
  17. tomwalsh77 thread starter macrumors regular

    tomwalsh77

    Joined:
    Feb 12, 2012
    Location:
    Blackpool, UK
    #17
    She doesn't have any groups, since I've been messing around with it last night it seems to be ok so far. I don't know what I've done but fingers crossed its fixed for good. :)
     
  18. henry72 macrumors 65816

    henry72

    Joined:
    Jun 18, 2009
    Location:
    New Zealand
    #18
    Check the "start new conversations from" settings on iMessage, both iMac and iPhone 6.

    I think Apple needs to simply this! I found this EXTREMELY annoying, they did combine different addresses form a same person on Mac's Messages app but not on iOS.

    Hope this help, if not, turn off iMessage on both device and turn it back on.
     

Share This Page