iMessage attachments/pics gone!

CosmoPilot

macrumors 65816
Original poster
Nov 8, 2010
1,440
109
South Carolina
iOS 8 has all your historical attachments now in details. Under iOS8, this worked perfect.

On iOS 8.0.2, they are now all missing. I have blank placeholds but no actual pictures, etc. can anyone confirm this behavior?
 
Last edited:

justinwebb

macrumors regular
Aug 23, 2009
222
0
iOS 8 has all your historical attachments now in details. Under iOS8, this worked perfect.

On iOS 8.0.2, they are now all missing. I have blank placeholds but no actual pictures, etc. can anyone confirm this behavior?
Mine shows them just fine and I have upgraded to 8.0.2
 

cynics

macrumors G4
Jan 8, 2012
11,630
1,906
Mine for the most part works. When I get what you have.



Simply clicking them makes them load.



What happens when you click on them? Are you on wifi? I know that shouldn't matter but I'm curious.

EDIT : Excuse the image size, tapatalk on iOS removed the sizing function a while back and never reimplemented it.
 

CosmoPilot

macrumors 65816
Original poster
Nov 8, 2010
1,440
109
South Carolina
When I tap any of the blank files, I get the same screen as post #3 above. What's strange, is all attachments that have been sent to me since 8.0.2 show just fine. All others are gone!

I have iCloud Drive turned on. Could this be the culprit?
 
Last edited:

leopard forest

macrumors newbie
Sep 28, 2014
2
0
I am having the same problem. I just updated to iOS 8.0.2 the day it was related. I did it through iTunes and did a full restore from a backup. Everything seemed to be working okay yesterday with messages until I let my phone battery die. When I plugged it back in to charge it seemed to take an unusually long time to boot back up. Now I have the same problem where all attachements do not appear. All the settings are correct to allow for attachments. All the attachements appear on my MacBook Air messages program. Any ideas?
 

Attachments

leopard forest

macrumors newbie
Sep 28, 2014
2
0
I am having the same problem. I just updated to iOS 8.0.2 the day it was related. I did it through iTunes and did a full restore from a backup. Everything seemed to be working okay yesterday with messages until I let my phone battery die. When I plugged it back in to charge it seemed to take an unusually long time to boot back up. Now I have the same problem where all attachements do not appear. All the settings are correct to allow for attachments. All the attachements appear on my MacBook Air messages program. Any ideas?

Here is the image.
 
Last edited:

kylemc

macrumors newbie
Oct 1, 2009
5
0
Same problem here after I let my phone battery die as well. No idea if the boot up took an abnormal amount of time, but from my day of digging around all else seems to be in working order.
 

JohnnyWannabe

macrumors newbie
Oct 22, 2014
4
1
Same issue

The majority of my attachments are gone too. It's not just imessage attachments, all other text conversation attachments are gone as well.

The only ones attachments are from a very old thread, and everything sent after 8.0.2

I'd really like them back. Has anyone found a way to find them and reattach to their respective conversation threads?
 

JohnnyWannabe

macrumors newbie
Oct 22, 2014
4
1
I do not have them set like that. I went through some other threads and found that the oldest pictures were still there. I tried to use recovery software to pull the attachments, and I found that there were only 86 message attachments on my backup. However, on last months backup, I had over 500 message attachments. So the files are either gone, with placeholders, or just corrupt. I don't know if I should wait for a fix, or if I should just cut my losses. What would you recommend?
 

irish2110

macrumors member
Jul 9, 2008
61
7
same issues

I'm having the same issues and I've looked everywhere for a fix...SOME older attachments are there but a majority of them are not! :mad:
 

Armen

macrumors 604
Apr 30, 2013
7,392
2,266
Los Angeles
Why aren't you people saving these pictures somewhere else if they are that important?

my pics are saved on camera roll, dropbox, hard drive attached to my Airport Extreme and even on another hard drive that is locked in a safe.
 

JohnnyWannabe

macrumors newbie
Oct 22, 2014
4
1
The majority of them are saved to a backup drive so its not a big deal, and I have an iTunes backup from when I was running 8.0, but it isn't an issue of losing the pictures, not entirely. It's more about being able to save the conversations in their entirety. It's about finally having the ability to look for historical attachments in the early parts of a conversation thread. And it's about no longer needing this particular functionality, because all the images are now gone.

But then again, I'm one of those guys that holds on to conversations. If you delete them, it's not an issue for you. And I understand that this didn't happen to everyone. But what about the ones it catches completely off guard? A conversation from a family member that is no longer around, or a friend who had his life tragically cut short. I can't help feel bad for any potential losses that cannot be recovered.

#overdramatic

----------

Besides, this is less about placing blame on those that don't back up their images, and more about finding out what caused the losses. And to find out if it is preventable, or if there is a way to recover the lost data. I mean, who expects a something like this would ever happen?
 
  • Like
Reactions: kikig2150

irish2110

macrumors member
Jul 9, 2008
61
7
iMessage attachments/pics gone!

contacted apple care about the situations...after going through several steps I was connected to a senior advisor....long story short...after reinstalls and restores...they basically said they don't know and could possibly be a bad back backup?
 

JohnnyWannabe

macrumors newbie
Oct 22, 2014
4
1
I agree that it could possibly be a bad backup, but what I want to know is what causes the backup to go bad, and why only in this particular way.

I still have my backup from before I updated to 8.0.2, and I was thinking about restoring back to it, and upgrading directly to 8.1, to see if it happens again. Of course, I don't know if its related to the 8.0.2 update, or if its something entirely coincidental. I won't lose too much data and I can save all the new stuff. The only thing I have against it, is that if I'm going to go through this much trouble, I'm half tempted to just give up and start over and delete everything.

meh
 

Glassed Silver

macrumors 68020
Mar 10, 2007
2,096
2,559
Kassel, Germany
Has anyone any new info on this?

I lost many attachments and the latest updates didn't fix a thing.

Really starting to wonder where the good old Apple quality went.
Big letdown, but not really surprised, data integrity isn't really an Apple priority. We see that in many of their decisions and omissions.


Glassed Silver:mac
 

Stuphilly

macrumors newbie
Dec 7, 2014
2
0
I agree that it could possibly be a bad backup, but what I want to know is what causes the backup to go bad, and why only in this particular way.

I still have my backup from before I updated to 8.0.2, and I was thinking about restoring back to it, and upgrading directly to 8.1, to see if it happens again. Of course, I don't know if its related to the 8.0.2 update, or if its something entirely coincidental. I won't lose too much data and I can save all the new stuff. The only thing I have against it, is that if I'm going to go through this much trouble, I'm half tempted to just give up and start over and delete everything.

meh
JohnnyW you seem to have looked into this quite a bit, were you ever able to get this fixed?
 

davidfr

macrumors newbie
Dec 29, 2014
1
0
Same problem

Hello
I Have the same problem.
2 days ago, I changed nothing and pictures / vidéo are gone from iMessage but still available on iMessage App on my Macbook air.

Any solution ?

David
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.