iMessage Block User Feature Gone..

Discussion in 'iOS 10' started by MistrSynistr, Sep 13, 2016.

  1. MistrSynistr macrumors 6502a

    Joined:
    May 15, 2014
    #1
    Anyone else notice this? Through messages you used to be able to go to a number's info, scroll down and "block contact/caller/sender" and it's missing now, what in the world? This is a great feature..

    Maybe someone has some info on this?
     
  2. crisandria macrumors newbie

    Joined:
    Sep 14, 2016
    Location:
    CT
    #2
    It's still there, but a bit more obscure. When your in the message tap on the circle I. Then tap on the name/number of the person texting you. that takes you to a page that you can create a contact, add to an existing contact, etc. and at the bottom there is block this caller.
     
  3. AJsAWiz macrumors 68040

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #3
    I called Apple (support) about this. Evidently you can only block those in your contact list, now. If they are not in your contact list, you can report it to Apple. I did this but nothing happened and I continue to get unwanted iMessages from someone I do not know. And to make bad, even worse this idiot has started a group conversation and added me and others I don't know. Apple needs to change this back to the way it used to work.
    --- Post Merged, Oct 30, 2016 ---
    Not true. If the person is not in your contact list the option to block does not appear. The only choices you have are Send Message, Share Contact, Create New Contact and Add to Existing Contact. I don't want to do any of these with someone I do not know.

    You can select the "i" with the circle around it to select "do not disturb" or if they have sent you a group iMessage you can select "leave this conversation" but you can't block anyone from there either.
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    Follow the steps that were laid out at http://forums.macrumors.com/threads/imessage-block-user-feature-gone.1995303/#post-23440413 a bit closer and you'll notice that you can get to a contacts screen that offers that option.
     
  5. AJsAWiz macrumors 68040

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #5
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    Strange. Seems like others are finding it fine, including me.
     
  7. TitsLegendary macrumors 6502

    Joined:
    Jun 12, 2013
    #7
    Maybe you've got a bad install? Just checked on my phone and it's definitely there. I can block numbers not in my contacts that have either called or texted me.
     
  8. leesweet macrumors demi-god

    leesweet

    Joined:
    Feb 1, 2009
    Location:
    Northern Virginia, USA
    #8
    I can't find it either, let me read that thread. It looks like you have to add them to a real contact (I have a 'blocked people' contact.) But I agree that it would be better to be able to block them directly without any other steps.

    ----
    Looks like merged threads and that link goes to this thread.. :) I've not been able to block any 'non contact' since 10, I believe.
     
  9. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #9
    It's basically what was mentioned in an earlier post:
     
  10. leesweet, Nov 1, 2016
    Last edited: Nov 1, 2016

    leesweet macrumors demi-god

    leesweet

    Joined:
    Feb 1, 2009
    Location:
    Northern Virginia, USA
    #10
    Right, you need to create or add it to a current contact. Before you could block it on its own. If that last section means there's a separate 'block on its own', let me see...

    Edit: Yep: it's there. I'm wondering if that came back because I'm pretty sure I looked at every contact link from an empty text phone number (that is, from someone I've never heard from before) and there was no way to block it. But it's there now. I'm on 10.2PB1 for what that's worth.
     
  11. rjcchan macrumors member

    Joined:
    Sep 23, 2015
    #11
    Phew! Cross fingers that this is really coming back
     
  12. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #12
    It's there even now, just takes an extra few steps to get to.
     
  13. Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
    #13
    It works fine. Just blocked a number that was in my messages that was not assigned a name. Took 3 seconds.
     
  14. rjcchan macrumors member

    Joined:
    Sep 23, 2015
    #14
    ok. found it. i had done it in iOS 10 but disremembered it wrong how to do it in 10.1
     
  15. AJsAWiz macrumors 68040

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #15
    Just tried again. Here's the route I took: Messages -> Selected the message -> tapped Detail, the I with the circle around it on the top right -> My only options on that screen are "Send My Current Location, Share My Location and Do Not Disturb; below that are the Images and Attachments tabs.
    That's all I see. Before the Block option was right here

    Would someone please post the step by step directions for blocking Messages? I gave up after calling Apple and they couldn't find it either.
     
  16. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #16
    As has been laid out before a number of times, after tapping the blue 'i' and going to the detail page you then need to tap on the contact name (or phone number) that appears at the top left of that details screen which will then take you to the contact screen where if you scroll all the way to the bottom you will see the block option.
     
  17. AJsAWiz macrumors 68040

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #17
    I've seen that solution here and tried it many times and it doesn't work for me. Here's what happens when I tap on the name/number of the person texting me: everything you mentioned appears EXCEPT (yes, I went to the bottom) the block this caller option. The last option (again, yes, I went all of the way to the bottom) is "Add to Existing Contact".

    Thanks for the reply but it's still not working for me. Perhaps I'll call Apple again, and get someone else this time. Or, better yet, stop by the Apple Store after the holiday frenzy has passed.
     
  18. C DM, Dec 1, 2016
    Last edited: Dec 1, 2016

    C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #18
    Well, that step wasn't mentioned when you described what you were doing earlier as you mentioned just accessing the details page by tapping on the blue 'i' icon and not going any further beyond that page.

    A post at http://forums.imore.com/ios-10/366314-blocking-people-ios-10-a-3.html#post2812460 shows it all with screenshots.

    Not sure why it's not working for you. I can definitely say it's there using a couple of devices running iOS 10, and based on a few users in this thread and some other similar ones it seems to work for others that have tried it.
     
  19. AJsAWiz macrumors 68040

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #19
    Just figured it out. I left out a "half, intermediary, step". I got it now.Woo hoo! Thanks for the lightening bolt which caused me to go back and take a better look.
     
  20. MistrSynistr thread starter macrumors 6502a

    Joined:
    May 15, 2014
    #20
    Sorry, I just saw this, and it works.

    The reason I couldn't find it is because there's some weird extra step where you can't just click on the the top circle/pic contact and down to block user, you have to click on the I one FIRST, then to the other screen that makes no sense when you can just click it when you open the message.

    Thanks for letting me know.
     
  21. AJsAWiz macrumors 68040

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #21
    You are not alone. I missed that extra step too.
     

Share This Page