iMessage confusion - help!

Discussion in 'iOS 5 and earlier' started by paulold, Nov 4, 2011.

  1. paulold macrumors 6502

    Joined:
    Mar 3, 2008
    Location:
    Washington, DC
    #1
    I have an iPhone 4S. My friend just got one too. It's his first iPhone. He kept his cell phone number. We're both on Verizon if that matters. Prior to us getting iPhones, we would text all the time. When I got my iPhone, no problems texting. But when he got his iPhone, he disappeared for a few days. I figured he was just busy. Turns out, his texts were not getting thru to my phone. After a few days I sent him a message and noticed it was blue, not green. I didn't know he already had his iPhone. And that night we realized the texts weren't going thru.

    Now my friend is confused because he has two iMessage conversations going on with me. One he thinks is to my cell phone number though those messages never get to me. The other is to my email address (which is the same as my Apple ID).

    How do we clean this up? He's able to call me on his phone. But he seems to be messaging me via my Apple ID instead of my cell phone number. And he doesn't want two separate conversation threads for me in his iMessage. Any ideas?
     
  2. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #2
    Two things:

    1. Both of you, Delete both conversations and start a fresh message.

    2. Both of you, go to Settings> Messages> Receive at> Caller ID> (Select your number as your Caller ID, not your Apple ID).
     
  3. gloss macrumors 601

    gloss

    Joined:
    May 9, 2006
    Location:
    around/about
    #3
    You might also want to dial *228, option 1 if you're on Verizon. It's an activation line - my wife's phone had issues until we did this.
     
  4. lefooey macrumors member

    Joined:
    Dec 26, 2009
    Location:
    Spokane, WA
    #4
    Close. Depends on whether or not you have multiple iOS 5 devices (such as an iPhone and an iPad) and you want to receive iMessages on both at the same time and respond from wherever is convenient.

    Settings -> Messages -> Receive At can have multiple addresses. Make sure you have your phone number (for his legacy messages) and your designated Apple ID (for more recent iMessages) listed.

    For Settings -> Messages -> CallerID, set the address where you'd prefer to receive responses for conversations you START. For example, I put my apple ID address here to be sure any responses come to all my devices, not just my phone.

    Once a conversation has started in iMessage (blue), then it only goes to the devices with the "receive at" set to the same address as the caller ID was when you began the conversation.

    Why have both addresses on "receive at"? This is so you get the message if your friend instead goes to their contact list (or starts a new message and just hits the + to add you) and chooses your email address instead of your phone number.
     
  5. paulold thread starter macrumors 6502

    Joined:
    Mar 3, 2008
    Location:
    Washington, DC
    #5
    settings messed up

    See, I think there's a problem with my Messages settings screen. I don't have the option to set my caller id or to set where I receive my messages. I also can't choose to Send Read Receipts. Another friend and I noticed that our setting screens for Messages are different even though we have identical phones on Verizon. The Messages settings screen looks different on my iPad too. There, I can set Send Read Receipts and Receive At (which can only be set to email addresses obviously, since it's not a phone).

    If I turn off Messages on my iPhone and then turn it back on, I have to re-enter all my info and I get to set those things mentioned above. But then it goes away when I am done. Here's my screenshot.
     

    Attached Files:

  6. maliu macrumors 6502a

    Joined:
    Jun 24, 2010
    #6

    Weird, when I check mine I have three more options between iMessage and the mMS option. Send receipts, Send as SMS and receive at. Receive at it is where you enter your phone number. You definitely don't have that choice.
     
  7. dotme macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #7
    Same thing happened to me tonight. iMessage has been working fine since Oct 14th but tonight, my wife said my iMessages were coming from my Apple ID and not my phone number. Whipped open messages settings, saw the same screen you have. Turned messages off, back on, got my options back. But I was still sending from my Apple ID even though the phone number was preferred.

    When she got home, I had her delete the SMS thread that had come from my Apple ID, and reply to an SMS from my phone number. Once she did that, I could reply and send her new messages and they came from my phone number again. It was strange - I fixed it, but I have no idea why it got borked to begin with.
     
  8. DVDSP macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    Southwick, MA
    #8
    I'm having trouble too

    My wife uses her iPhone and iPad for iMessage but the conversations only sync when messages are sent to her email address. If an iMessage is sent to her phone number it is completely inaccessible from her iPad.

    I thought that all iMessages would sync across devices. Is that incorrect?

    Also, on both of our phones we do not have the option to specify anything other than our phone number as the primary "receive at". It's grayed out.
     
  9. Alonzo84 macrumors 6502a

    Alonzo84

    Joined:
    Dec 18, 2009
    Location:
    North Carolina
    #9
    It will only show up on an iPad or iPod Touch if you have iMessage set to be received at your AppleID or other email address in addition to your phone number. The phone number is grayed out on your iPhone because it's your phone number and can't be changed. This is also where SMS messages will be sent if iMessage fails. You should be able to set multiple email addresses for iMessages to be received at but the phone number is permanent for your phone.
     
  10. DVDSP macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    Southwick, MA
    #10
    I misread an earlier post. I was looking at "receive at" instead of "Caller ID". I'll have to change that on her phone and give it a try.
     
  11. sk1wbw Suspended

    sk1wbw

    Joined:
    May 28, 2011
    Location:
    Williamsburg, Virginia
    #11
    Yeah, this whole iMessage thing between an iPhone and an iPad is confusing for me too. I was never getting iMessages on my iPad but I'm playing with settings that were mentioned above and hopefully it'll work right.
     

Share This Page