iMessage creates multiple threads after iOS 8 update

fcooner

macrumors newbie
Original poster
Sep 6, 2014
5
0
Hi all,

I did a clean install of iOS8 on my 5s. Set everything up again, like I have numerous times. That includes checking my iMessage settings. I only send/receive from my phone number.

I am getting iMessage messages from the same three people in two separate threads. 2 are on ios7. One is on ios8. The two on ios7 are in one thread. The one on ios8 is in the other thread. All three see all posts in one thread...

Ideas?
 

AppleChic76

macrumors 6502a
Sep 13, 2014
617
304
Hi all,

I did a clean install of iOS8 on my 5s. Set everything up again, like I have numerous times. That includes checking my iMessage settings. I only send/receive from my phone number.

I am getting iMessage messages from the same three people in two separate threads. 2 are on ios7. One is on ios8. The two on ios7 are in one thread. The one on ios8 is in the other thread. All three see all posts in one thread...

Ideas?
Dunno but this happened to me and my bestie today (she's on iOS 8 on a 5s; I'm on a 6). We've been texting just fine since Friday when I got it but all of a sudden today my iMessage started showing up using my iCloud address. Totally weird.
 

wepiii

macrumors 6502a
Sep 22, 2012
526
116
Go to settings, messages, and make sure the send & receive addresses are the same on all devices
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
48,526
17,183
Go to settings, messages, and make sure the send & receive addresses are the same on all devices
And the friends should do the same, especially the ones with iOS 8 as well.
 

dictoresno

macrumors 601
Apr 30, 2012
4,208
472
NJ
yup, happened to me as well when i started using ios8 on my iPhone 5S. my phone decided, mid convo, to start sending iMessages as my iCloud email vs my phone number. it only happened a few times, to two different contacts. in turn, it also started sending my messages/convos to my iPad and iMac as well. i thought it was something wrong with handoff or something and even made a thread about it last week. all my message settings were correct, as number only. it has to be an iMessage bug.
 

fcooner

macrumors newbie
Original poster
Sep 6, 2014
5
0
Oddly, the issue just righted itself... Not sure why. Nothing has changed since yesterday.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.