iMessage detection woes?

Discussion in 'iPhone' started by Bowsa2511, Nov 21, 2013.

  1. Bowsa2511 macrumors regular

    Joined:
    Oct 21, 2013
    #1
    Hi guys, yesterday I bought a new iPhone 5s for my mom, and set her up with a New Apple ID for iCloud/Facetime, but my Apple ID for her app-store purchases. Question is the funkiness of iMessage. When she's on Wifi and selects my number to text, it automatically detects me as an iOS user and sends the message as an iMessage automatically. But when I do the same thing from my phone, her number shows up as "green" as sends it as an MMS/Text message, the only "blue/iMessage" portion of her contact information is her iCloud ID. Why isn't it detecting her phone number as iCloud compatible automatically? Is there a way to fix this?
     
  2. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #2
    Check her iMessage settings under Send and Receive. Looks like it might have the number greyed out or missing. Usually knocking off and on iMessage fixes this.
     
  3. jer04 macrumors regular

    jer04

    Joined:
    Nov 17, 2012
    Location:
    Townsville, Australia
    #3
    I had this problem just a couple of days ago. I fixed it by turning off the iMessage, hard reset the phone by pressing home+power till apple logo shows up and then turn back on the iMessage.

    Simply turning off and on iMessage or hard reset didn't fix it...the combination of two, however, fixed my problem.
     
  4. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #4
    You can also try this. Use the country code in front of her phone number. And in your contacts list make sure her number is identified as "iPhone" and not "Mobile."

    I had to enter country codes for iMessage to see my friends iPhones in the UK and Australia.

    For a US number it would look like this: +1(123) 456-7890

    Hope that helps.
     

Share This Page