iMessage = E-mail?

Discussion in 'iPhone' started by Anthony T, Oct 14, 2011.

  1. Anthony T macrumors 6502a

    Joined:
    Jul 10, 2008
    #1
    I'm sending iMessages to my friends, but when she receives it, my e-mail address shows up rather than my phone number or contact name she has for me in her phone. Is this normal?
     
  2. EddyP macrumors 6502

    Joined:
    Feb 12, 2010
    #2
    Settings - Messaging - and somewhere in there is an option to select what "caller ID" you show people. Sorry I don't have my phone with me now.

    You can choose your mobile number or email address.
     
  3. Anthony T thread starter macrumors 6502a

    Joined:
    Jul 10, 2008
    #3
    I do see it. In the Messaging Settings, I see it says "Receive At" and then it says "2 Addresses". When I select that it shows my Apple ID, and then it says "You can be reached for messages at:" and lists my phone and e-mail, but my phone number is darkened out and I can't select it. Under "Caller ID" though, my phone number is checked off, yet it still displays my e-mail when I iMessage someone.
     
  4. xcel360 macrumors regular

    Joined:
    Jul 25, 2008
    Location:
    WPB, Fl
    #4
    Do they have your email saved in your contact card on their iPhone? That might help having your name show up instead of your email address.
     
  5. mattx7 macrumors newbie

    Joined:
    Oct 14, 2011
    #5
    I'm having the same problem ... is there any way that this can be fixed???
     
  6. Anthony T thread starter macrumors 6502a

    Joined:
    Jul 10, 2008
    #6
    It's weird though, because when I text my brother, my contact name shows up fine.
     

Share This Page