iMessage going as normal SMS since 5.0.1?

Discussion in 'iOS 5 and earlier' started by WeegieMac, Nov 11, 2011.

  1. WeegieMac Guest

    WeegieMac

    Joined:
    Jan 29, 2008
    Location:
    Glasgow, UK
    #1
    Only noticed this tonight when sending a mate who I know has an iPhone 4, a text.

    I also tried family with iPhones, and their messages stay "green" and don't turn "blue" to signify an iMessage.

    The feature is switched on, and I done a clean install of 5.0.1 last night.
     
  2. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #2
    Go to Settings-->Messages and turn off "Send as SMS" option. Sometimes, if the iMessage can't be sent, the iPhone sends it as SMS instead. This makes it so that it will send iMessages every time.

    You can still send SMS though but if you have iMessages contacts, it will make sure to only send iMessages.
     
  3. WeegieMac thread starter Guest

    WeegieMac

    Joined:
    Jan 29, 2008
    Location:
    Glasgow, UK
    #3
    Cheers mate.

    Thing is though, on iOS 5.0, I never changed any settings for messages.

    If I selected someone who owned an iPhone running iOS 5, the colour changed from Green to Blue, all automatic.
     
  4. r2shyyou macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #4
    I just now sent an iMessage as a test for another thread and there was no issue. However, I'm in the US on AT&T and I believe you're in the UK so me not having an issue probably doesn't mean much to you. In any case, perhaps try toggling iMessage on/off to see if that has any effect.
     
  5. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #5
    Yeah, but the thing is, it only sends SMS if there is some trouble sending off an iMessage. So I assume there was a reception problem or something and that's why it fired off an SMS instead since it couldn't send an iMessage.
     
  6. WeegieMac thread starter Guest

    WeegieMac

    Joined:
    Jan 29, 2008
    Location:
    Glasgow, UK
    #6
    Yeah, I'm on O2 in the UK.

    I've switched iMessage off (I also tried the above test by turing off Send As SMS, but still when selecting contacts who own iPhone's on iOS 5, the name remains green in colour), and it's now awaiting activation. So we'll see what happens when it eventually comes back on.

    Odd.

    ----------

    Yeah, true, but it's acting the same regardless of that toggle ... I select someone who I know is using an iPhone with iOS 5, and their name stays green. Could be a network issue, no big deal, it'll sort itself out no doubt.
     

Share This Page