iMessage going from E-mail

Discussion in 'iOS 8' started by matty.p, Jun 20, 2014.

  1. matty.p macrumors 6502

    Joined:
    Jun 24, 2010
    Location:
    Portland, OR
    #1
    I realize this is a common problem even in the current iOS 7 versions but I've never ran into this issue until going to Beta 1 and now Beta 2. I have iMessage set up with my iCloud e-mail and my phone number, the settings say start new messages from my number but 90% of my messages are going from my iCloud E-mail. It's mostly just an annoyance to those who are receiving messages from me, but I was curious if anyone else was experiencing this with the betas.
     
  2. sp44 macrumors member

    Joined:
    Sep 18, 2006
    #2
    I get the same. My phone number is greyed out in the settings.
     
  3. afsnyder macrumors 65816

    Joined:
    Jan 7, 2014
    #3
    iMessage doesn't let you get rid of your phone number for iMessage.

    On that note, if you lose cell reception or internet, iMessage has a tendency to switch over to email from time to time. If you delete the thread and remessage, it should go back to your phone number.
     
  4. matty.p thread starter macrumors 6502

    Joined:
    Jun 24, 2010
    Location:
    Portland, OR
    #4
    I've deleted threads, reset all settings and did a restore of beta 2 (for other reasons as well). All haven't seemed to fix my issues. May just unlink iCloud from messages but I don't know how that'll affect it on the mac.
     
  5. sp44 macrumors member

    Joined:
    Sep 18, 2006
    #5
    It's still listed but I can only have a "check" by the email address and the phone number is greyed out.
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    It's grayed out because you can't remove it as it's there by default when you have a number associated with the phone.
     
  7. iolinux333 macrumors 68000

    Joined:
    Feb 9, 2014
    #7
    iMessage is one of the most confusing things I've ever run into in a lifetime of computing. I don't think I'm alone. In fact I don't think Apple even really understands the thing. I wish they'd just open source it and let us have at it. Over at XDA we'd eventually have a decent client on Android after a while too.
     
  8. wbiggart macrumors newbie

    Joined:
    Jun 8, 2005
    #8
    I also had this problem, and it was super annoying to fix. I tried turning off and back on iMessage, logging out of my Apple ID in both iMessage and the App store, restarting the phone, and then wiping and doing a fresh install of beta 2.

    None of those solutions worked for me.

    Ultimately I was able to fix the problem simply by going to Settings > Messages > Send & Receive and tapping to uncheck all the email addresses so that only my phone number had a check box in the area Titled "You can be reached by iMessage at".

    Worked for me, but YMMV.
     
  9. sp44 macrumors member

    Joined:
    Sep 18, 2006
    #9
    I got it by unchecking the email address too. That turned off iMessage. I turned iMessage back on and the check showed up on my number.
     

Share This Page