iMessage Help - Incorrect phone number stored in iMessage setting

Discussion in 'iPhone' started by The Great Boony, Oct 14, 2011.

  1. The Great Boony macrumors regular

    Joined:
    Nov 23, 2010
    #1
    Hi Guys,

    Can anyone help with this issue?:

    When I bought my iPhone I used it with the number the network provided, then had my old number ported across.

    The problem is now, that my iPhone is displaying the number my network provided and I am not able to use iMessage.

    The correct number is Stored both on iTunes Sync Screen and in the iPhone phone settings, but the wrong number is stored in the iMessage settings

    Please help!
     
  2. maths2k macrumors member

    Joined:
    Apr 11, 2010
    Location:
    Leicester, UK
    #2
    Me too!

    I think I have a similar issue.

    My problem is that when I send a message, and it goes through the iMessage route, the number coming up on the other phone is the old one.

    If I send a text not through IMessage then it is my current mobile number.

    Would like to know how to fix this.
     
  3. firuze macrumors newbie

    Joined:
    Oct 14, 2011
    #3
    Slightly different

    Mine is a similar issue, except that my phone number isn't coming up at all, only an email address that I can't remove.

    ----------

    Turn iMessage off, and then on again. (so stupid I didn't do it before, even turned my phone off and on). My number then came up and verified it. Hopefully it will recognise your new number
     
  4. nweash macrumors newbie

    Joined:
    Dec 28, 2008
    #4
    call me crazy but any message sent via iMessage is through an email address and your cell# is bypassed. thats why in iMessage settings your cell # is grayed out, and also why you aren't charged for texting.


    if you check your iMessage conversations and scroll to the top and click on contact they will have an email highlighted in blue meaning you're contacting them through that not their cell#
     
  5. FuzzyWuzzzy macrumors newbie

    Joined:
    Oct 14, 2011
    #5
    Just turn it off and back on and it will update!
     
  6. sixtwenty3dc macrumors newbie

    Joined:
    Oct 18, 2011
    #6
    Same issue. Wrong phone number in iMessage. cant change or verify new

    I have the same issue. Changed from AT&T to Verizon and had issues porting my old number over, which have now cleared up. However, iMessage settings still reflect the temporary number VZW gave me (that is not being used now)

    Have used Verizon's *228 phone update feature, rebooted the phone, turned iMessage off/on, turned all messaging off / on, and still it shows the incorrect number, and is trying to verify to that number.
     
  7. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #7
    No, it also works with phone numbers, over cellular data or wifi. Mine and my friends both have the cell numbers highlighted in blue, since that's what we set as the primary caller ID.

    If someone has it set as an email, then their email addy would be highlighted in blue.
     
  8. The Great Boony thread starter macrumors regular

    Joined:
    Nov 23, 2010
    #8
    Seems like a few are having the same issue... Might email Apple to see if there is a workaround
     
  9. dotme macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #9
    Back up phone. Power off. Remove SIM. Power on. Erase all content and settings. Power off. Insert SIM. Power on. Restore.

    I'm guessing, but I really think this is what I would try if it were happening to me.
     
  10. sugar iphone macrumors newbie

    Joined:
    Jul 7, 2013
    #10
    Well i guess i fixed it
    1)turn off imessage
    2) go to contacts and create your own contact with only your own number, no email
    3)go to settings-phone-my number, and type in your number without the +61
    4)go to settings-general-date and time. make sure the 'set automatically' is on
    5)go to settings-mail,contacts,calenders, then in my info, select your own contact.
    6)forget your wifi network and then join again
    7) turn on imessage.
    it should work. it worked for me. step 3-6 doesnt necessarily have to be in that order.
    Sorry i copied and pasted this off another answer of mine
     

Share This Page