iMessage Help

Discussion in 'iPhone' started by testdrive, Jul 15, 2012.

  1. testdrive macrumors member

    Joined:
    Mar 1, 2012
    #1
    I want to start texting my friend in the UK but texting regularly costs per message. We both have the iPhone 4S and was wondering how would I be able to send him message using wifi/data plan on imessage and what would be the setup to make sure if message doesn't get delivered by imessage, the message just doesn't get sent.

    Would it make a difference if I was to send a message to the apple id vs the cell phone number? Please give the setup so messages aren't sent via the carrier.
     
  2. bandofbrothers macrumors 601

    bandofbrothers

    Joined:
    Oct 14, 2007
    Location:
    Uk
    #2

    You will know as iMessages are sent in able bubble and sms in a green bubble.

    Just turn on iMessages in your setting and attach your apple id and phone number.

    Get your friend to do the same and both of you being on iOS 5+
     
  3. HenryHealy macrumors member

    Joined:
    Nov 1, 2011
    #3
    Make sure you both have it turned on. Also, in the text box in messages of this contact, it should say iMessage with a blue bubble.
     
  4. JML42691 macrumors 68020

    JML42691

    Joined:
    Oct 24, 2007
    #4
    Go to Settings > Messages > Turn "Send as SMS" off.

    This will cause a failed iMessage to simply not send rather than defaulting to SMS, however this applies universally to all of your iMessage contacts.
     
  5. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #5
    Or u can put airplane mode on and turn wifi back on it'll only send as an iMessage that way
     

Share This Page