iMessage - How to...

Discussion in 'macOS' started by xplnusa, Oct 8, 2012.

  1. xplnusa macrumors regular

    Joined:
    Nov 17, 2009
    Location:
    Idaho
    #1
    Is there a way that I can get iMessage on my desktop and laptop to sync anytime I add an account or contact so that it doesn't matter where I'm sitting I get the messages? I've noticed my iMac seems to see my incoming messages from other iPhone/iMessage users, but my laptop only seems to get messages from AIM and Facebook...
     
  2. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #2
    Yes. Ensure that your operating system is version OS X 10.8.2 (any earlier versions will not be able to sync with your phone number). It sounds like you already have one computer working, so I presume you also have an iPhone running iOS 6 (which is the other requirement). Ensure that your computer is linked to the same iCloud account as the phone. When you open Messages it should ask if you'd like to associate with your phone number; if you choose to, you will receive a notice on your phone and computer that your latest device is now using the phone number.

    If you're not receiving the prompt about the phone number, check your preferences to see if it's listed there. If not, the general advice is to disable iMessage on your computer and on your phone, then re-enable it on your phone, and then re-enable it on your computer. That should bring it up.

    A few other things that you're probably aware of, but that bear mentioning. First, the syncing across devices only occurs with messages sent through iMessage; SMS texts, AIM messages, etc. will not sync. Also, iMessage is not limited to your phone number; if you've added other addresses that you can be reached at, people could choose to send messages to an email address and they would still be able to reach you. In that case, only devices that are set to receive messages at that email address will receive the messages. This becomes doubly important because Apple's "caller ID" settings are imperfect: I have had it happen where, even though all of my devices are set to use my phone number as "caller ID," one device apparently switched over to using one of my email addresses instead. I had no indication that it happened; my contact alerted me to it.
     
  3. xplnusa thread starter macrumors regular

    Joined:
    Nov 17, 2009
    Location:
    Idaho

Share This Page