iMessage in 7.0.3 still not activating on number

Discussion in 'iOS 7' started by manuelcalavera, Oct 22, 2013.

  1. manuelcalavera macrumors newbie

    Joined:
    Oct 18, 2013
    #1
    Anyone else having problem activating iMessage on number ?
    I thought they had fixed the issue in 7.0.3.
     
  2. Crossmax macrumors member

    Joined:
    Oct 23, 2013
    #2
    I cannot activate iMessage or FaceTime on my iPhone 4 since 7.0.3. I simply get a "Could not log in. Check your network connection and try again" message when attempting to log on with my Apple-ID. Had no such issues on 7.0.2. Any suggestions of what to do?
     
  3. gee38l macrumors newbie

    Joined:
    Apr 9, 2010
    #3
    Yeah im still having issues
     
  4. manuelcalavera thread starter macrumors newbie

    Joined:
    Oct 18, 2013
    #4
    Then ''fixed activation bug'' has not happened.
     
  5. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #5
    I just turned mine off then back on and the activation took about 3 seconds.

    Back in the early days of iMessage, it was better to turn off WiFi to activate iMessage, maybe try that? Does it help anymore?

    Maybe with some insight as to how iMessage activates can chime in and comment? My understanding is it sends a text then the system replies via data. Is that still how it works or was that only in the old days?
     
  6. creativedogmedia macrumors 65816

    creativedogmedia

    Joined:
    Jun 26, 2011
    #6
    Go into your device and remove the email address and then add it again...that should provide the option to select either of the two (or both).
     
  7. imacadoo, Oct 23, 2013
    Last edited: Oct 23, 2013

    imacadoo macrumors member

    Joined:
    Oct 11, 2012
    Location:
    Westchester, NY
    #7
    I tried turning off wifi and turning off the email addresses and it didn't work. Didn't activate (no problems before this update). Then I did a reset (held home and off button till apple appeared), logged in with apple id and still got the error message but then magically it activated, phone and email. Turned wifi back on and so far it is active.

    EDIT: Well, it deactivated. Really frustrating.
     
  8. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #8
    That's indeed how it works, which makes your 3 second estimate sound a little on the short side!

    The iPhone sends a silent SMS message to Apple with some data to identify the device and your phone number. They process that and link it to your Apple ID.

    Apple then sends an SMS back to the phone with some more identifying data to complete the activation.

    The process assumes that your can send and receive the SMS to/from Apple.
     
  9. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #9
    Interesting. I wonder if it uses wifi if available, because sometimes when I enable it, it literally takes 2-3 seconds.

    I am curious as to why they haven't incorporated it right into the Apple ID now that mac and iOS require apple ID to get into it.
     
  10. benguild macrumors 6502a

    Joined:
    Jul 29, 2003
    #10
    I get this occasionally when switching SIM cards. Toggling iMessage off and back on (as well as FaceTime) always fixes it for me, though.
     
  11. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #11
    It must use SMS because that's the only way they can verify your phone number actually "belongs" to you.
     
  12. Yptcn macrumors 6502a

    Yptcn

    Joined:
    Aug 24, 2012
    Location:
    Paris
    #12
    On a previous iOS I had that issue and after calling Apple care a dozen times , finally someone told me that :

    -Date & Time must be turned ON
    - Time zone must be turned ON

    That fixed the issue and phone automatically activates . The SMS goes through .

    I'm not sure if it's the same with iOS 7 as I always leave those settings on now and have never had problems since. It's worth giving it a try .;)
     

Share This Page