iMessage in iOS7

Discussion in 'iOS 7' started by duxy, Sep 18, 2013.

  1. duxy macrumors newbie

    duxy

    Joined:
    Mar 2, 2012
    Location:
    Brookline, MA
    #1
    First off - Loving iOS7 so far!

    Two questions / things I've noticed.

    In iMessage - all of a sudden my messages are being sent from my icloud address (when i text people it comes up in a new thread on their phone and instead of my number it shows my icloud address). I know I fixed this when iMessage first rolled out, but can't seem to find that fix in iOS7 now.

    Second - looks like the "Time Stamps" in iMessage have also disappeared (from the conversation view). Anyone else noticing this?
     
  2. matttye macrumors 601

    Joined:
    Mar 25, 2009
    Location:
    Lincoln, England
    #2
    Re: timestamps, just drag the conversation window to the left and ALL timestamps appear. :)
     
  3. Eitel macrumors regular

    Joined:
    Sep 20, 2012
    #3
    Slide the window to the left to see the time stamps.
     
  4. duxy thread starter macrumors newbie

    duxy

    Joined:
    Mar 2, 2012
    Location:
    Brookline, MA
    #4
    Ooh - look at that! haha - thank you!
     
  5. !GS51! macrumors regular

    Joined:
    Jan 26, 2013
    #5
    Its simple to fix the imessage problem, just go to settings > messages and check the send and receive options probably your icloud email is set to send
     
  6. WordMasterRice macrumors 6502a

    Joined:
    Aug 3, 2010
    Location:
    Upstate NY
    #6
    1. If you go to Messages in settings you can select the send from address.

    2. If you drag left to right in the conversation view (anywhere in the part where the chat bubbles are) it will show you timestamps for each message.
     
  7. duxy thread starter macrumors newbie

    duxy

    Joined:
    Mar 2, 2012
    Location:
    Brookline, MA
    #7
    Yeah I went there, but it won't let me choose my phone number for some reason. The other two options are my @me and @icloud emails. The number is also listed, but is gray'ed out.
     
  8. !GS51! macrumors regular

    Joined:
    Jan 26, 2013
    #8
    Its supposed to be greyed out in "you can be reached by.."

    But you will be able to select your Phone number in "Start new conversations from"
     
  9. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #9
    the number is greyed because its a phone and the number is allowed by default.

    go to message settings, send & receive. scroll down where it says "start new conversations from" and uncheck your email address and check mark your number.
     
  10. duxy thread starter macrumors newbie

    duxy

    Joined:
    Mar 2, 2012
    Location:
    Brookline, MA
    #10
    Thank you all for the help! I realized it was gray'ed out because I am underground with only Wifi service. Went above ground and all is right again!
     
  11. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #11
    you can still send imessages from your phone number without cell service and on wifi only.
     
  12. jwc6160 macrumors member

    Joined:
    Aug 17, 2011
    #12
    At least yours works. I still can't get iMessage to connect. 2 hours in. My text bill is going to suck this month unless something gets fixed.
     
  13. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #13
    its all because of the servers getting hammered.
     
  14. duxy thread starter macrumors newbie

    duxy

    Joined:
    Mar 2, 2012
    Location:
    Brookline, MA
    #14
    True - but I think because I updated the new iOS with zero cell service, it took longer to verify the number for iMessage. It literally was gray until I went above ground and worked instantly. So maybe just a one-time verification thing...who knows.
     
  15. a1000wtp macrumors newbie

    Joined:
    Sep 20, 2013
    #15
    I have to opposite question. Im trying to get my phone number OFF of iMessage. This is not my primary phone, but i still use iMessage over wifi and ever since the iOS7 update a lot of my texts are being routed to my iphone rather then my primary phone. Since my numbers greyed out I cant uncheck it. suggestions?
     
  16. tigres macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #16
    Updated ipad mini.

    It will not allow me to add my primary iCloud email comes up as error. No phone number is an option either.

    iCloud settings does not have an option to add another iCloud acct. At a.ll either.

    Cannot seem to figure this out:confused:
     

Share This Page