iMessage (inactive)

Gabri

macrumors member
Original poster
Aug 21, 2011
37
1
I upgraded to a new rMBP 15" and did a clean install, everything is fine but iMessage. In the preferences it says that the account is (inactive) although it's enabled and everything, handoff is working even with messages although I can't send or receive messages on the MBP.

I tried lots of things with no luck, signing out of iMessage on the laptop, signing out of iMessages from my iPhone, iPad and Laptop, signing out of iCloud account. Still it's always (inactive) and I can't even remove it using the "-" sign at the bottom cause it's greyed out.

Any idea how can I get it working?
 

sharbeen

macrumors member
Aug 13, 2013
43
7
United Arab Emirates
I upgraded to a new rMBP 15" and did a clean install, everything is fine but iMessage. In the preferences it says that the account is (inactive) although it's enabled and everything, handoff is working even with messages although I can't send or receive messages on the MBP.

I tried lots of things with no luck, signing out of iMessage on the laptop, signing out of iMessages from my iPhone, iPad and Laptop, signing out of iCloud account. Still it's always (inactive) and I can't even remove it using the "-" sign at the bottom cause it's greyed out.

Any idea how can I get it working?
I have got the same problem today. No idea how to fix it.
Looks like we need to submit a feedback to Apple with regard to this matter. I found a way to fix but that is not what I want. When I switch my location to US it works instantly. That is appleID account needs to be switched to US (not the iMessage location). But I pay with my UAE credit card for my 50GB and i don't want to lose that.
 

mujtaba.mir

macrumors 6502a
Oct 16, 2014
531
398
Looks like we need to submit a feedback to Apple with regard to this matter. I found a way to fix but that is not what I want. When I switch my location to US it works instantly. That is appleID account needs to be switched to US (not the iMessage location). But I pay with my UAE credit card for my 50GB and i don't want to lose that.
Strangely, I did nothing for 2 days with it, and just signed in this morning and things are back to normal. No change of location or anything.
 

Gabri

macrumors member
Original poster
Aug 21, 2011
37
1
Strangely, I did nothing for 2 days with it, and just signed in this morning and things are back to normal. No change of location or anything.
I contacted my operator and the CS told me that he "refreshed" my account, everything worked as normal after this.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.