iMessage (inactive)

Discussion in 'OS X Yosemite (10.10)' started by Gabri, Feb 21, 2015.

  1. Gabri macrumors member

    Joined:
    Aug 21, 2011
    #1
    I upgraded to a new rMBP 15" and did a clean install, everything is fine but iMessage. In the preferences it says that the account is (inactive) although it's enabled and everything, handoff is working even with messages although I can't send or receive messages on the MBP.

    I tried lots of things with no luck, signing out of iMessage on the laptop, signing out of iMessages from my iPhone, iPad and Laptop, signing out of iCloud account. Still it's always (inactive) and I can't even remove it using the "-" sign at the bottom cause it's greyed out.

    Any idea how can I get it working?
     
  2. mujtaba.mir9 macrumors regular

    mujtaba.mir9

    Joined:
    Oct 16, 2014
    Location:
    UK
    #2
    I have got the same problem today. No idea how to fix it.
     
  3. sharbeen macrumors member

    Joined:
    Aug 13, 2013
    Location:
    United Arab Emirates
    #3
    Looks like we need to submit a feedback to Apple with regard to this matter. I found a way to fix but that is not what I want. When I switch my location to US it works instantly. That is appleID account needs to be switched to US (not the iMessage location). But I pay with my UAE credit card for my 50GB and i don't want to lose that.
     
  4. mujtaba.mir9 macrumors regular

    mujtaba.mir9

    Joined:
    Oct 16, 2014
    Location:
    UK
    #4
    Strangely, I did nothing for 2 days with it, and just signed in this morning and things are back to normal. No change of location or anything.
     
  5. Gabri thread starter macrumors member

    Joined:
    Aug 21, 2011
    #5
    I contacted my operator and the CS told me that he "refreshed" my account, everything worked as normal after this.
     

Share This Page